Download it now!
Bug 105941 - MAILMERGE: crash when use MailMerge service and then terminate the desktop
Summary: MAILMERGE: crash when use MailMerge service and then terminate the desktop
Status: RESOLVED DUPLICATE of bug 85651
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-02-11 15:43 UTC by Simone
Modified: 2017-02-16 14:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["SfxItemPool::Put(SfxPoolItem const &,unsigned short)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simone 2017-02-11 15:43:46 UTC
This bug was filed from the crash reporting server and is br-81cadfdc-cec7-41b8-8cbc-fdc9c0025a27.
=========================================

Hi, when I create the "com.sun.star.text.MailMerge" service and then call xDesktop.terminate() a crash occurs.
I better explained when the crash occurs and how to reproduce it at the following link.
http://stackoverflow.com/questions/42170214/libreoffice-crash-when-perform-a-mail-merge-in-c-sharp
Comment 1 Buovjaga 2017-02-14 11:07:43 UTC
Ok, I got a comment from a mail merge dev: it's a known problem that creation of a MM Job without executing it fails: http://opengrok.libreoffice.org/xref/core/postprocess/qa/services.cxx#131
Comment 2 Buovjaga 2017-02-14 11:12:16 UTC

*** This bug has been marked as a duplicate of bug 85651 ***
Comment 3 Simone 2017-02-16 13:53:13 UTC
(In reply to Buovjaga from comment #1)
> Ok, I got a comment from a mail merge dev: it's a known problem that
> creation of a MM Job without executing it fails:
> http://opengrok.libreoffice.org/xref/core/postprocess/qa/services.cxx#131

Thanks but the problem occurs even when I execute the Mail Merge job.

Is this the same problem?
Do I have to create a new crash report?

On GitHub there are both examples: with and without the Mail Merge job executed.
Comment 4 Buovjaga 2017-02-16 14:36:54 UTC
(In reply to Simone from comment #3)
> Thanks but the problem occurs even when I execute the Mail Merge job.
> 
> Is this the same problem?
> Do I have to create a new crash report?
> 
> On GitHub there are both examples: with and without the Mail Merge job
> executed.

No idea. We would have to find someone to fix bug 85651 first. Of course, you are free to investigate it, if you want to dive into LibreOffice internals.