Bug Hunting Session
Bug 105958 - Cancel does not undo changes made in Chart Data Ranges dialogue, and no Undo available.
Summary: Cancel does not undo changes made in Chart Data Ranges dialogue, and no Undo ...
Status: RESOLVED DUPLICATE of bug 62595
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-12 15:38 UTC by Gavin D
Modified: 2017-02-12 15:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gavin D 2017-02-12 15:38:45 UTC
Description:
There is no way to exit the chart editing dialogue, Data Ranges, after making a selection, without the chart being updated with the new selection. It doesn't matter whether the OK, Cancel or Close (X) button is clicked, or the dialogue is closed by means of the Escape key, the newly selected, potentially erroneous data range appears on the chart, and there is no undo function that reverses the action.

Steps to Reproduce:
1.) Double-click a chart to edit it.
2.) Right-click the chart and select Data Ranges...
3.) On the Data Series tab, click the minimize icon next to the Categories field.
4.) Select any cell range.
5.) Close the Data Ranges dialogue by any means possible.

Actual Results:  
The cell range selected above becomes the range applied to the chart, regardless of the operation being canceled. No undo option is able to reverse the selection and revert to chart to its original content.

Expected Results:
On clicking OK, one would expect the desired changes to be implemented. However, selecting Cancel, Close (X), or hitting Escape, should close the editing dialogue without performing any changes to the chart. In any case, clicking Undo should revert the chart to its pre-edited state.


Reproducible: Always

User Profile Reset: No

Additional Info:
This process was tested using LibreOffice 5.1.3.2 on Linux Mint 17.3 64-bit, and LibreOffice 5.2.0.4 on Windows 7 64-bit. Locale is en_ZA.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Jean-Baptiste Faure 2017-02-12 15:52:25 UTC
Known problem: currently chart edits are not undoable via ctrl+Z.
See bug 62595.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 62595 ***