Bug Hunting Session
Bug 106006 - Can not use Type 1 font (pfm)
Summary: Can not use Type 1 font (pfm)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL: http://nabble.documentfoundation.org/...
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-02-14 18:33 UTC by Fabien08FR
Modified: 2017-02-14 23:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Doc example with two pfm fonts and png screenshot (117.11 KB, application/x-7z-compressed)
2017-02-14 18:33 UTC, Fabien08FR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabien08FR 2017-02-14 18:33:04 UTC
Created attachment 131218 [details]
Doc example with two pfm fonts and png screenshot

After upgrading to 5.3.0.3, Type 1 font (like font_file_name.pfm) are not listed in the font list (checked with Calc, Draw and Write). Text document using this font (or svg pictures included in doc) are displayed with an alternative font. 

No bug previously with 5.2.x (no tested) neither with 5.3.0.0alpha+ (tested)

If i embed the font in the doc, same result (embeding with alpha+) (despite the file is very huge (8488 Ko as the fonts are only 4 Ko), perhaps an other bug to file). 

https://en.wikipedia.org/wiki/PostScript_fonts#Printer_Font_Metric
Comment 1 V Stuart Foote 2017-02-14 19:24:21 UTC
By design, support for Type 1 and bitmap fonts has been dropped at 5.3
Comment 2 Fabien08FR 2017-02-14 23:23:15 UTC
OK Thanks ! 

I will better search for solutions next time. Search engines don't gave me the information. I didn't think to look for deprecation. Now i have to find a functional font. (It's not a bug, it's a feature ;-) )