Bug 106017 - FORMATTING: TOC from old LO-Version mailformed formatted
Summary: FORMATTING: TOC from old LO-Version mailformed formatted
Status: RESOLVED DUPLICATE of bug 104315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2017-02-15 09:48 UTC by mini-matze
Modified: 2021-01-11 13:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
step 1 (4.36 KB, image/png)
2017-02-15 09:49 UTC, mini-matze
Details
step 2 (13.81 KB, image/png)
2017-02-15 09:49 UTC, mini-matze
Details
step3 (45.42 KB, image/png)
2017-02-15 09:50 UTC, mini-matze
Details
step 4 (4.39 KB, image/png)
2017-02-15 09:50 UTC, mini-matze
Details
step 5 (3.97 KB, image/png)
2017-02-15 09:50 UTC, mini-matze
Details
used template (created with older version) (60.12 KB, application/vnd.oasis.opendocument.text-template)
2017-02-15 09:51 UTC, mini-matze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mini-matze 2017-02-15 09:48:51 UTC
Description:
If you open a document from an old LO-Version (<5.3) the toc entries are mailformed formatted. Spaces between the title (E) and an tab (T) strips the left side (max one char). The tab himself is mailformed, too. The width and the used sign is wrong!

OS/LibreOffice version: Windows 10 Education 64bit / Libreoffice 5.3.0.3 (Info: UI-Renderer: Standard; Layout-Engine: neu;)

Tested on two pcs with Windows 10 and Windows 7.

Steps to Reproduce:
-Open the template (document.ott) [Pic 01]
-Update the toc [Pic 02]
--The Tab is currupt and the title is strip at the end
-Open Toc-settings and remove the space between E and T [Pic 03]
-The stipping ist gone, but tab is still wrong (if you reset the space the stripping is already there! Multiple spaces strips always only one char!) [Pic 04]
-Delete toc and create new one -> everything works fine, also after change the entries (add tab and spaces and so on - see 04.png) [Pic 05]

Actual Results:  
-Tab has now function until delete and recreate the toc.
-Entry were stripped if any character were added behind of them.

Expected Results:
Toc is formated correctly (like in LO <5.3)
Tab through the end of the line and no stripping of the title after adding a space behind this entry.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 mini-matze 2017-02-15 09:49:42 UTC
Created attachment 131233 [details]
step 1
Comment 2 mini-matze 2017-02-15 09:49:55 UTC
Created attachment 131234 [details]
step 2
Comment 3 mini-matze 2017-02-15 09:50:07 UTC
Created attachment 131235 [details]
step3
Comment 4 mini-matze 2017-02-15 09:50:19 UTC
Created attachment 131236 [details]
step 4
Comment 5 mini-matze 2017-02-15 09:50:31 UTC
Created attachment 131237 [details]
step 5
Comment 6 mini-matze 2017-02-15 09:51:07 UTC
Created attachment 131238 [details]
used template (created with older version)
Comment 7 mini-matze 2017-02-15 09:58:33 UTC
Sorry for this second post, but there is something wrong explained (and no edit possible).

After creating the new toc, the tab is formatted correctly, but the stripping is always there! Just add a space after the "E".
Comment 8 Xisco Faulí 2017-02-15 10:02:37 UTC
Regression introduced by 250252d02bac88877845a4bc27e3f1837f1312ba, which is the
same commit as in bug 104315. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 104315 ***
Comment 9 mini-matze 2017-02-15 10:14:48 UTC
Sorry for the duplicate, I searched for TOC and Table of Content (which is a mess of entries) and have not seen the entry.

But this is not exacly a duplicate, because of the also mailformed TAB if you open the document and update that. This happens independently from the striped entry. It seems this are two bugs which I comment. Please check if this is also addressed with the commit you posted. 

See step 1 (open the old) and step 2 (only update of the toc). The Tab is completly wrong (sign/width). I need to recreate the complete toc to repair the tab.

Thank you very much! Bye
Comment 10 mini-matze 2017-02-15 10:27:09 UTC
OK - is the same, too. He strips the tab completly, because of an space after the tab. Sorry for my comment - one more time :-)

Have a nice day. Great job, great product!
Comment 11 barrowsannabell 2021-01-11 13:36:47 UTC
I was also facing this problem in my recent days but did not get any help. Finally, I found your post and it was really helpful for me. By now, I can start work with my https://www.assignmentmasters.co.uk/btec-assignment/ website and your post was really helpful for this work. Thanks.