Download it now!
Bug 106030 - FORMATTING/VIEWING: Rotating of the cell text is done by text direction only, while letters are not rotated together with the text.
Summary: FORMATTING/VIEWING: Rotating of the cell text is done by text direction only,...
Status: RESOLVED DUPLICATE of bug 100986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-15 16:27 UTC by gstoyanov
Modified: 2017-02-16 07:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Exel rotated text examples. (119.80 KB, image/png)
2017-02-15 16:28 UTC, gstoyanov
Details
LibreOffice Calc result when importing the same Excel file. (182.35 KB, image/png)
2017-02-15 16:31 UTC, gstoyanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gstoyanov 2017-02-15 16:27:03 UTC
Description:
In some spreadsheets I need to save space. Therefore, I rotate some cell text used as column header at 90 degrees. The behavior in MS Excel is what I am expected, but in LibreOffice Calc it is different. Calc rotates only the direction of text content of the cell, but the letters are not rotated and overlap each other.
See the attached pictures.

Steps to Reproduce:
1. Put some text in a cell.
2. Select menu "Format" -> "Cells ..."
3. Rotate to some angle (for ex. 45 degrees).

Actual Results:  
Text direction of the text is rotated at specified angle but the letters are not.

Expected Results:
The whole text is rotates like picture. See the attached pictures.


Reproducible: Always

User Profile Reset: Yes. Resetting the profile did not solve the issue. However, starting in safe mode works as I expected (no problems in safe mode).

Additional Info:
The version tested is LibreOffice 5.3.0.3 Portable.

Restarted Calc in Safe Mode. The ISSUE WAS SOLVED!
Then I reset the user profile as recommended and restarted Calc. The problem appears again. After another test in safe mode and a new user profile reset the issue still happens.



User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 gstoyanov 2017-02-15 16:28:21 UTC
Created attachment 131255 [details]
Exel rotated text examples.
Comment 2 gstoyanov 2017-02-15 16:31:03 UTC
Created attachment 131256 [details]
LibreOffice Calc result when importing the same Excel file.

The image shows the unexpected rotation in Calc of the cell text and letters.
The Excel file is use as an example. The same happens if in a new Calc document the text is manually entered in a cell and then rotated.
Comment 3 V Stuart Foote 2017-02-16 07:34:42 UTC
A duplicate of bug 100986, see cmnt 18 there.

Disable OpenGL rendering and should have better result.

Safe mode disables OpenGL rendering, allowing GDI+ rendering where HarfBuzz supports rotated text correctly.

*** This bug has been marked as a duplicate of bug 100986 ***