Download it now!
Bug 106050 - Finder Icons Are Blank After Upgrade/Install
Summary: Finder Icons Are Blank After Upgrade/Install
Status: RESOLVED DUPLICATE of bug 98540
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2017-02-16 18:54 UTC by Orion
Modified: 2017-02-16 22:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Blank icons in Finder. (34.06 KB, image/png)
2017-02-16 18:57 UTC, Orion
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Orion 2017-02-16 18:54:54 UTC
Description:
For the last several versions of 5.X, after upgrading LO, the Finder icons for all ODF files have gone blank (picture attached). This is a common enough problem that there are several discussion boards in which it has been asked and answered: 

* http://www.mac-forums.com/os-x-apps-and-games/309103-documents-icons-blank-libre-office.html
* https://ask.libreoffice.org/en/question/86416/icons-missing-in-mac/
* https://ask.libreoffice.org/en/question/45093/what-happened-to-my-filetype-icons-in-osx/
(there are more)

In the past, I could clear the icon cache in OS X, but with "Sierra" (v10.12), that area of the computer is now locked, so the workaround is no longer functional. 

Steps to Reproduce:
1. Upgrade. 
2. Look in Finder. 

Actual Results:  
Finder Icons of ODF (and any other file set to load in LO) are blank (generic Mac icons: white with folded corner).

Expected Results:
ODF icons should appear with colour-coded icons: blue for Writer, green for Calc, etc. 


Reproducible: Always

User Profile Reset: No (it's not a problem within LO)

Additional Info:
Colour-coded icons are visible in (a) the "Icon" view in Finder (rather than "List"), and (b) when my laptop is plugged into a bigger screen (i.e., my home monitor instead of the monitor on the laptop). 


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Orion 2017-02-16 18:57:00 UTC
Created attachment 131283 [details]
Blank icons in Finder.

This is what ODF icons look like in Finder after an LO upgrade.
Comment 2 V Stuart Foote 2017-02-16 22:10:08 UTC
Can not confirm this.

Icon view, and list view of ODF documents show in Finder with the ODF generic icons by document type.

@Alex--dupe of bug 98540

=-testing-=

On macOS 10.12.3 with
Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Mac OS X 10.12.3; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

*** This bug has been marked as a duplicate of bug 98540 ***