Bug 106060 - Calc - Formula drag & Autofill - The values of the filled formula cells include only first sheet values
Summary: Calc - Formula drag & Autofill - The values of the filled formula cells inclu...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoFill
  Show dependency treegraph
 
Reported: 2017-02-17 13:36 UTC by u81
Modified: 2020-10-29 04:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A part (15.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-17 22:45 UTC, Jacques Guilleron
Details
137 sheets counting from 1 to 450 with error (366.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-18 16:14 UTC, u81
Details

Note You need to log in before you can comment on or make changes to this bug.
Description u81 2017-02-17 13:36:24 UTC
Description:
I have a calc file with about 180 sheets.

In a sheet called totals - I've used formulae to get the totals of the same cell in sheet numbers 6 -175 . 

The formula works fine/ displays properly in Calc 4.2.8 but in version 5.2.5 + 5.3.0.3 it doesn't work.

I've changed the options > calc > formulae   Reference format Excel A1 as I'm using the indirect funtion in the sheet as well.

For example - the formula reads - =sum('6'.c15:'175'.c15)   - where first sheet name is 6 and the last sheet name to get the values from is sheet 175. This formula worked fine.

then I drag and autofill this for the column > the cell with the above formula shows the value from sheet 6 cell c15 only & all of the autofilled cells show the values from sheet 6 only .  i.e. the values in cells on sheets 7 to sheets 175 are ignored and not added in.

I hope I've explained my problem clearly.

Steps to Reproduce:
1.I opened a new file and setup 4 sheets.
2.In sheet 2 cell a1 I entered 1 and dragged and autofilled up to 15.
3.I copied cell a1 to a15 from sheet 2 and pasted them in sheets 3 and 4.
4.I went to sheet 1 cell a1 and entered =sum( > clicked on sheet 2 cell a1 > held shift and clicked on sheet 4 tab (to select all sheets from 2 to 4) > clicked sheet 4 cell a1.
5.sheet 1 cell a1 showed 3 - the expected value
6.I dragged and autofilled sheet 1 cell a1 formula to sheet 1 cell a15
7.All values displayed correctly.

Hence, problem did not occur.

Then I 
8.added another 172 sheets.
9.on sheet 2 I extended the values from cell a1 to a450 i.e. 1 to 450
10. I copied these to sheets 2 - 176.
11. I then ran the same sum formula in sheet 1 i.e. =sum(Sheet2!A1:Sheet176!A1) and it only returned 1 as opposed to 175.
12.I dragged the formula down and had the same problem.

Actual Results:  
As above

Expected Results:
the formula only fetched values from sheet 2 as opposed to giving the sum of values in cell a1 of sheet 2 to sheet 176


Reproducible: Sometimes

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Builds ID: LibreOffice 5.3.0.3


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Comment 1 Jacques Guilleron 2017-02-17 14:27:13 UTC
Hi u81,

Your formulas are written for Excel.
In Calc, you have to change "!" by "."
=sum(Sheet2!A1:Sheet176!A1)in Ecxel has to be written
=sum(Sheet2.A1:Sheet176.A1)

Does this works?
Comment 2 u81 2017-02-17 14:56:26 UTC
Hi,

Thanks for the prompt response.

I understand that the formula was written for excel, but it works absolutely fine in version 4.2.8.2.

It also works fine as is in version 5.2.5 if the number of sheets was kept to 3 or so but when I increased the number of sheets to 175, the formula stopped working and hence, I don't think it has anything to with the syntax.

If it were anything to with syntax, then it wouldn't have worked for 3 sheets nor for 175 sheets.

Did you try reproducing the error with my steps above.
Comment 3 u81 2017-02-17 15:01:47 UTC
I'm sorry, I forgot to mention that I just wrote the formula in the bug report from memory.

When you click the cells for the sum range the syntax comes up automatically.
Comment 4 Jacques Guilleron 2017-02-17 22:45:38 UTC
Created attachment 131307 [details]
A part

I did only a part of the job.
Can you provide the file where you find those issues?

Thank you,

Jacques
Comment 5 u81 2017-02-18 16:14:49 UTC
Created attachment 131320 [details]
137 sheets counting from 1 to 450 with error

Hello again,

I used the file you created in the attachment. > 

I extended the counting on sheet 2 from 1 to 450 >

I copied and pasted 1 to 450 from sheet 2 to all sheets after sheet 1 >

I dragged your formula on sheet 1 cell a15 to cell a450 and the problem shows.

I've attached the file with the problem showing for your kind reference.

Thanks
Comment 6 Jacques Guilleron 2017-02-19 10:41:42 UTC
Hi u81,

Up to 99 copies, values are displayed. At 100, calculated values disappear and only the values of the second sheet are displayed.
When I uncheck all OpenCL Options in Tools > Options > LibreOffice > OpenCL,
I get again the displaying of all calculated values.
Can you try and confirm it?

Jacques
Comment 7 u81 2017-02-19 10:47:30 UTC
Hi Jacques,

I wish to confirm that on unchecking the the option for "Allow use of Software interpreter (even when OpenCL is not available) and restarting Libre Office I get the values back.

However, this has to be some kind of a bug anyway, so could you kindly mark the bug confirmed, please?

Thanks for your prompt attention to this.
Comment 8 QA Administrators 2018-10-29 03:57:29 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2020-10-29 04:32:37 UTC
Dear u81,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug