Bug 106078 - TRACK CHANGES: no tooltips on changes if GTK3
Summary: TRACK CHANGES: no tooltips on changes if GTK3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords: notBibisectable
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2017-02-18 16:26 UTC by Jean-Baptiste Faure
Modified: 2017-04-12 16:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file with track changes enabled (17.47 KB, application/vnd.oasis.opendocument.text)
2017-02-18 16:26 UTC, Jean-Baptiste Faure
Details
screencopy with GTK3 (140.88 KB, image/png)
2017-02-18 16:27 UTC, Jean-Baptiste Faure
Details
screencopy with GTK2 (161.81 KB, image/png)
2017-02-18 16:27 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2017-02-18 16:26:34 UTC
Created attachment 131321 [details]
test file with track changes enabled

When track changes is enabled, there is no tooltip visible on a change when the cursor is in this change. These tooltips are essential to track changes functionality because it the mean to know who did a given change selected in the text.
The bug is related to GTK3, because the tooltips are visible if GTK2 is used instead of GTK3.

Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: single

Seen too in my own build of version 5.3.1.0.0+ and master, so not related to Ubuntu packaging.

Version: 5.3.1.0.0+
Build ID: e38914af31b0150a383cc556e634da48eceb1dbc
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk3; Moteur de mise en page : nouveau; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Version: 5.4.0.0.alpha0+
Build ID: 9bc537b7943bc4d82e759b394941f89c35658516
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2017-02-18 16:27:16 UTC
Created attachment 131322 [details]
screencopy with GTK3
Comment 2 Jean-Baptiste Faure 2017-02-18 16:27:43 UTC
Created attachment 131323 [details]
screencopy with GTK2
Comment 3 Jean-Baptiste Faure 2017-02-18 16:54:56 UTC
Add keyword regression because with the current backend (GTK3) it does not work while it worked with previous default backend GTK2.

Best regards. JBF
Comment 4 Aron Budea 2017-02-19 06:16:10 UTC
Confirmed with 5.4 master build and 5.1.4.2 bundled with Ubuntu 16.04.

Version: 5.4.0.0.alpha0+
Build ID: c910d1dae1a9fcf0591098244debc863dd59618a
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 5 Caolán McNamara 2017-04-10 13:02:23 UTC
possibly the problem here is requesting a tooltip area with 0 width
Comment 6 Commit Notification 2017-04-10 14:18:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb433f83a5f66dd1ca8ed0c62ef9cc0761b7f0ac

Resolves: tdf#106078 get bounding box of commented region for gtk3 tooltips

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2017-04-10 14:18:50 UTC
that should do it, backport to 5-3 in gerrit
Comment 8 Jean-Baptiste Faure 2017-04-11 05:09:51 UTC
(In reply to Caolán McNamara from comment #7)
> that should do it, backport to 5-3 in gerrit

Indeed, it does in master. Thank you very much.

Version: 5.4.0.0.alpha0+
Build ID: b076e8f673d1714ee8b6f991eb2ca299b6fa8949
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: single

Best regards. JBF
Comment 9 Commit Notification 2017-04-12 16:06:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=244d2abb6c1bcd89cedf773d8721f62451708c3f&h=libreoffice-5-3

Resolves: tdf#106078 get bounding box of commented region for gtk3 tooltips

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.