Bug 106082 - STATUSBAR: tooltips and contextual menu for zoom widget are not translated
Summary: STATUSBAR: tooltips and contextual menu for zoom widget are not translated
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.6.1 rc
Hardware: All All
: medium normal
Assignee: Christian Lohmaier
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2017-02-18 21:07 UTC by Jean-Baptiste Faure
Modified: 2017-02-28 05:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screencopy of tooltip of zoom widget in the statusbar (69.16 KB, image/png)
2017-02-18 21:07 UTC, Jean-Baptiste Faure
Details
Screenshot of the area on Ubuntu 14.04 LO 5.3.0 (65.06 KB, image/png)
2017-02-18 23:20 UTC, Gabor Kelemen
Details
bisection logs (7.10 KB, text/plain)
2017-02-26 21:04 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2017-02-18 21:07:33 UTC
Created attachment 131327 [details]
screencopy of tooltip of zoom widget in the statusbar

In the French UI (localization complete) the tooltips of the zoom widget are not translated: "Zoom In", "Zoom Out", "Zoom level. Right-click to change zoom level or click to open Zoom dialog."
It seems that these string are not marked as translatable.

Best regards. JBF
Comment 1 Gabor Kelemen 2017-02-18 23:20:24 UTC
Created attachment 131329 [details]
Screenshot of the area on Ubuntu 14.04 LO 5.3.0

Can not reproduce with:

Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~trusty1.1
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk2; Moteur de mise en page : nouveau; 
Locale : hu-HU (hu_HU.UTF-8); Calc: group

These seem to be translated to French (and to Hungarian as well).
No idea why does it not work for you.
Comment 2 Jean-Baptiste Faure 2017-02-19 07:34:19 UTC
Sorry, I see this problem in 5.3.1.0.0+ and master, not in 5.3.0.3 (from Ubuntu in my case).

Best regards. JBF
Comment 3 Xisco Faulí 2017-02-19 11:56:24 UTC
Does resetting the profile fix it ?
Comment 4 Jean-Baptiste Faure 2017-02-19 14:53:27 UTC
(In reply to Xisco Faulí from comment #3)
> Does resetting the profile fix it ?

No, alas.

Best regards. JBF
Comment 5 Jean-Baptiste Faure 2017-02-21 09:33:41 UTC
I checked my local copy of translations. The translation of the tooltips for the zoom slider are in
translations/source/fr/svx/source/stbctrls.po
and my local copy has the strings in French

As now my phone line has been repaired, I did a new local clone of branch libreoffice-5-3 but I have the same problem with this local repository.

If I am not wrong these tooltips related to zoom slider are in the file ../program/resource/svxfr.res. I found the English strings in this file in my own builds for 5.3.2.0.0+ and 5.2.7.0.0+ and in the test build for LO 5.2.6 RC1. Finally I installed the test build for LO 5.2.6.1 with FR localization and a new user profile and it has the same behavior.
I tested the Italian localization of LO 5.2.6 RC1 with the same behavior as for French.

So I guess there is a problem with the merge of translations.

Additionally the contextual menu on the zoom value in the status bar is in English to for, at least, French and Italian.

Best regards. JBF
Comment 6 Jacques Guilleron 2017-02-21 11:15:26 UTC
Hi Jean-Baptiste,

I confirm tooltip for Zoom level is not translated in 
../program/resource/svxfr.res 
and also contextual menu for Zoom value in
LO  5.2.6.1 Build ID: e37e437cb0cfa0eab9d2e98a23f5074ae118d3df
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL

Jacques
Comment 7 Jean-Baptiste Faure 2017-02-21 12:58:01 UTC
(In reply to Jacques Guilleron from comment #6)
> Hi Jean-Baptiste,
> 
> I confirm tooltip for Zoom level is not translated in 
> ../program/resource/svxfr.res 
> and also contextual menu for Zoom value in
> LO  5.2.6.1 Build ID: e37e437cb0cfa0eab9d2e98a23f5074ae118d3df
> Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
> Locale : fr-FR (fr_FR); Calc: CL
> 
> Jacques

Hi Jacques,

Thank you for your tests. I added the regression keyword because the versions 5.3.0 (build from Ubuntu) and 5.2.5 (TDF Build) do not have this bug.

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2017-02-26 21:03:29 UTC
I bisected this bug on the 5.2 branch. The first bad commit is:

commit 3687612a93813449cfc68ce5ece3b785560b2e58
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Fri Feb 3 08:35:59 2017 +0100

    tdf#105707 PPTX import: warn when SmartArt is missing DrawingML fallback
    
    By the time DiagramGraphicDataContext::onCreateContext() completes, we
    know if there will be a DrawingML fallback for the SmartArt (called
    ExtDrawing in the code) or not.
    
    Warn about this case once at the end of the import when in interactive
    mode. Headless mode silently ignores the warning as expected.
    
    (cherry picked from commit ae828495be9c2ac5fdb4c1747ed7bdd51e5d87a7)
    
    Conflicts:
        include/svx/dialogs.hrc
        oox/source/core/xmlfilterbase.cxx
    
    Change-Id: I2bfeeedcaa244f08d8a0c208167e79d7bb697e6d
    Reviewed-on: https://gerrit.libreoffice.org/33873
    Tested-by: Jenkins <ci@libreoffice.org>
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
    Tested-by: Caolán McNamara <caolanm@redhat.com>

Best regards. JBF
Comment 9 Jean-Baptiste Faure 2017-02-26 21:04:06 UTC
Created attachment 131487 [details]
bisection logs
Comment 10 Commit Notification 2017-02-27 12:13:57 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9eaa17e6bb35a2cb71ec59c96ea4a39466789667

tdf#106082 fix missing statusbar translations (l10ntool is picky about syntax)

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-02-27 12:15:33 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4717dafe916d81f1c70ea0c51cb1342624116422&h=libreoffice-5-3

tdf#106082 fix missing statusbar translations (l10ntool is picky about syntax)

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-02-27 12:15:41 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-3-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=331c747cdd61192d1584a2016c927aabb465d7b3&h=libreoffice-5-3-1

tdf#106082 fix missing statusbar translations (l10ntool is picky about syntax)

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-02-27 12:17:15 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=558c3d3c83c85c4392eae491165143736477216b&h=libreoffice-5-2

tdf#106082 fix missing statusbar translations (l10ntool is picky about syntax)

It will be available in 5.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-02-27 12:47:56 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=000fee9930159d1bdd362b0db7b8332615e06dd4&h=libreoffice-5-2-6

tdf#106082 fix missing statusbar translations (l10ntool is picky about syntax)

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Adolfo Jayme 2017-02-27 19:28:52 UTC
Fixed by Cloph to expose the missing string to Pootle, where it’ll be dealt with gradually by individual translation teams.
Comment 16 Jean-Baptiste Faure 2017-02-28 05:46:52 UTC
Verified fixed in 5.2.7.0.0+, 5.3.2.0.0+ and master.

Thank you very much.

Best regards. JBF