Download it now!
Bug 106083 - Calc chart y-axis title not displayed correctly in LibreOffice 5.3
Summary: Calc chart y-axis title not displayed correctly in LibreOffice 5.3
Status: RESOLVED DUPLICATE of bug 100986
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-19 01:15 UTC by pegrego
Modified: 2017-02-27 15:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
same chart in 5.3.0 (top) and 5.2.5 (lower). Note y-axis title (525.82 KB, application/vnd.oasis.opendocument.graphics)
2017-02-19 01:15 UTC, pegrego
Details
Sample spreadsheet to confirm bug (22.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-19 18:48 UTC, pegrego
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pegrego 2017-02-19 01:15:40 UTC
Created attachment 131333 [details]
same chart in 5.3.0 (top) and 5.2.5 (lower). Note y-axis title

I upgraded from LibreOffice 5.25(Win x86) to 5.3( Win 64), and find that the y-axis title in x-y plots created in versions prior to 5.3 are no longer displayed correctly.  This is a title that is rotated by 90 degrees, so that it is parallel to the y-axis. In 5.3 the y-axis title is compressed horizontally and is illegible.  Attempts to fix the issue by editing the chart were not successful.  
I reverted to version 5.2.5, and the axis title is correctly displayed.
Please see the attachment for an example of the problem.  The top plot shows the plot as displayed in version 5.3, the lower plot shows the same plot in version 5.2.5.
Operating system: Windows 10.
Comment 1 Joel Madero 2017-02-19 04:34:24 UTC
Can you please provide the original file - not an odg with images in it? This isn't enough to allow us to reproduce.

Marking as NEEDINFO, once you attach the original dataset with graph (presumably ods file) please set to UNCONFIRMED.
Comment 2 pegrego 2017-02-19 18:48:44 UTC
Created attachment 131341 [details]
Sample spreadsheet to confirm bug

I have attached a copy of the spreadsheet where I first saw the bug.
Comment 3 Xisco Faulí 2017-02-19 18:57:44 UTC Comment hidden (obsolete)
Comment 4 pegrego 2017-02-21 23:07:40 UTC
I installed libo-master~2017-02-18_23.35.38_LibreOfficeDev_5.4.0.0.alpha0_Win_x86

In SAFE MODE the y-axis title appears correctly.
In NORMAL MODE the bug shows up as before - the y-axis title is unreadable.

I have also confirmed that the bug is present in both x86 and x64 versions of version 5.3.0, but is not present in x86 and x64 versions of version 5.2.5
Comment 5 Dave E 2017-02-22 21:06:33 UTC
I have this same problem.  It appears to be with the rotation of the font characters about their bottom orientation point.  Rotating +90 (as is normal for a Y axis) gives unreadable text, which appears to be outside the view-able "character area."  However rotating -270 allows one to see the characters, they are just not oriented correctly.

Tested with the 64-bit 5.3 distribution and with daily build:
master~2017-02-22_04.35.00_LibreOfficeDev_5.4.0.0.alpha0_Win_x86.msi
on 64-bit Win10 machine.  

As noted by pegrego, in both cases, opening in Safe mode eliminated the issue, but in normal mode, it returned.  Also occurred with charts created with older Calc versions as well an new ones.
Comment 6 Jacques Guilleron 2017-02-26 22:34:25 UTC
Hi all,

Did you try to uncheck "Use hardware acceleration", "Use OpenGL for all rendering"
into  Tools > Options > LibreOffice > View: Graphics Output 
and restart LO. 
Does this change the vertical displaying of the Y axis Title?
Perhaps have you found something else?
Is it an issue which happens each time?

Jacques
Comment 7 V Stuart Foote 2017-02-27 15:43:22 UTC

*** This bug has been marked as a duplicate of bug 100986 ***