Bug 106084 - certain EMF images from OOXML document are not rendered correctly LibreOffice
Summary: certain EMF images from OOXML document are not rendered correctly LibreOffice
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2017-02-19 04:45 UTC by MALLESH SUBRAMANI M
Modified: 2017-09-11 12:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
this is a lab manual from my college (798.83 KB, application/wps-office.docx)
2017-02-19 04:47 UTC, MALLESH SUBRAMANI M
Details
this the screen shot of first page when opened using wps office on ubuntu libre office writer (69.59 KB, image/png)
2017-02-19 04:50 UTC, MALLESH SUBRAMANI M
Details
Extracted emf imaged which illustrate the issue. (328.15 KB, application/x-zip-compressed)
2017-03-28 14:21 UTC, Bartosz
Details
Image which shows lack of drawing Bezier lines and transformations (14.07 KB, image/x-emf)
2017-04-19 13:48 UTC, Bartosz
Details
Interested image extracted from document, which could be used for testing purposes (22.66 KB, image/x-emf)
2017-04-27 14:47 UTC, Bartosz
Details
image1 emf inserted into LO 550alpha0 master (238.72 KB, image/png)
2017-06-09 12:07 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MALLESH SUBRAMANI M 2017-02-19 04:45:28 UTC
Description:
the images like electric circuit diagrams which were saved using ms office does not show up in libre office even when openGL or CL is enabled or disabled but the same file is opening prpoerly in wps office or ms office and even the print preview screen doesnt show up the image

Actual Results:  
i tried to enable and disable the openGL and CL but the output is same and unaffected

Expected Results:
the image should have shown up


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 MALLESH SUBRAMANI M 2017-02-19 04:47:46 UTC
Created attachment 131334 [details]
this is a lab manual from my college
Comment 2 MALLESH SUBRAMANI M 2017-02-19 04:50:58 UTC
Created attachment 131335 [details]
this the screen shot of first page when opened using wps office on ubuntu libre office writer
Comment 3 MALLESH SUBRAMANI M 2017-02-19 04:55:10 UTC
the same problem happens in libre office installed on windows 10 too
Comment 4 Julien Nabet 2017-02-19 13:39:49 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.

There are lots of logs but I noticed this one repeated several times:
warn:writerfilter:7184:1:writerfilter/source/dmapper/OLEHandler.cxx:242: OLEHandler::getCLSID: unhandled m_sProgId: RFFlow4
Comment 5 V Stuart Foote 2017-02-19 16:37:02 UTC
Confirmed, but issue is *not* with the OOXML document--it is with our handling of the EMF images in the archive.  

Export from MS Word 2007 to an ODF document also corrupts images on opening in LO Writer.

Extracted the media folder from the document, and there are 40 images--39 are .emf

Of the half dozen .emf I tested, none are rendered correctly on insert or open with LO Draw.

=-testing-=
Windows 10 Pro 64-bit en-US with
Version: 5.3.0.3 (x64)
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1

Version: 5.4.0.0.alpha0+
Build ID: 6de3688cc6bd52ce08ff8a4327e59dbbc8a5c7d4

Version: 4.4.6.3
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d

Version 3.6.7.1 (Build ID: 9418c72)
Comment 6 Thomas Woltjer 2017-02-19 17:17:22 UTC
Also reproduced on LO 5.3.0.3 on 64-bit Manjaro Linux.
Comment 7 Bartosz 2017-03-28 14:21:35 UTC
Created attachment 132223 [details]
Extracted emf imaged which illustrate the issue.
Comment 8 Julien Nabet 2017-03-28 19:02:23 UTC
Bartosz: since you assigned yourself, let's put the status to ASSIGNED.

If it was a mistake, don't hesitate to revert the statut and reset Assignee field.
Comment 9 Bartosz 2017-04-09 00:44:43 UTC
Review for this issue is available at:
https://gerrit.libreoffice.org/36287
Comment 10 Commit Notification 2017-04-13 16:37:29 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe62003caabf7665d41085c5d16f177f8186fce4

tdf#106084 EMF+ Add support for EmfPlusScaleWorldTransform record

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Bartosz 2017-04-19 13:48:43 UTC
Created attachment 132687 [details]
Image which shows lack of drawing Bezier lines and transformations
Comment 12 Bartosz 2017-04-19 21:26:12 UTC
You could find comparison of images after fixes on website:
https://wiki.documentfoundation.org/ReleaseNotes/5.4#Filters
Comment 13 Bartosz 2017-04-27 14:47:40 UTC
Created attachment 132904 [details]
Interested image extracted from document, which could be used for testing purposes
Comment 14 Commit Notification 2017-04-29 18:54:52 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb2f3e524919444d84974fe3216edd8fafc28e10&h=libreoffice-5-3

tdf#106084 EMF+ Add support for EmfPlusTranslateWorldTransform record

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Bartosz 2017-05-08 23:02:53 UTC
The issue was resolved with commit https://gerrit.libreoffice.org/#/c/37319/
Comment 16 Xisco Faulí 2017-06-09 09:53:47 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 17 V Stuart Foote 2017-06-09 12:07:02 UTC
Created attachment 133925 [details]
image1 emf inserted into LO 550alpha0 master

(In reply to Xisco Faulí from comment #16)
> Hello,
> Is this bug fixed?
> If so, could you please close it as RESOLVED FIXED?

Looks to be only partially resolved. See for example EMF image1.emf image from the zip'd media directory extracted from the OOXML (attachment 132223 [details])

On Windows 10 Home 64-bit en-US with
Version: 5.5.0.0.alpha0+
Build ID: d8e704ef30a6d7f606e58b25be54bbe79c9e40b6
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-02_00:43:23
Locale: en-US (en_US); Calc: CL
Comment 18 Xisco Faulí 2017-09-11 08:44:01 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.