Bug 106093 - Cell Contents not announced by Orca when using the arrow keys to navigate a spreadsheet
Summary: Cell Contents not announced by Orca when using the arrow keys to navigate a s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2017-02-20 01:19 UTC by am_dxer
Modified: 2017-03-01 10:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description am_dxer 2017-02-20 01:19:53 UTC
Description:
When using the arrow keys to move around a spreadsheet in Calc, Orca does not reliably read the cell contents

Steps to Reproduce:
1. Open Calc and use the arrow keys to navigate. Notice that Orca does not speak the cell coordinates.
2. Enter data in two cells and confirm the entry with the enter key or one of the arrow keys. After the second entry is complete, orca will read the data in each cell and  cell coordinates when navigating with the arrow keys, however, this information is not voiced after the first entry.
3. Continue typing data into cells and notice that after each entry Orca no longer speaks cell coordinates or the contents of a cell when using the arrow keys to navigate between each cell.

Actual Results:  
Orca does not speak cell information

Expected Results:
Orca should speak the contents of a cell and its corordinates when moving between cells with the arrow keys.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: ae17a85c2baf9f2ad97270e97bc372e61c7e3678
CPU Threads: 4; OS Version: Linux 4.9; UI Render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 am_dxer 2017-02-20 12:04:48 UTC
This works correctly in LibreOffice 5.2 and 5.3 so this is a regression in LibreOffice and not an Orca problem. My guess is that LibreOffice is not firing the correct accessible events.
Comment 2 am_dxer 2017-02-22 17:19:16 UTC
Can anyone confirm this or is it only in my setup? If this is indeed a problem, it is a serious regression as it prevents blind users of Orca from accessing the spreadsheet.
Comment 3 Joanmarie Diggs 2017-02-24 11:53:40 UTC
It looks like events have gone missing. The expected events are object:active-descendant-changed and object:selection-changed.
Comment 4 Xisco Faulí 2017-02-24 12:41:40 UTC
Regression introduced by:

author	Kohei Yoshida <kohei.yoshida@collabora.com>	2016-11-22 03:56:46 (GMT)
committer	Kohei Yoshida <libreoffice@kohei.us>	2016-11-22 13:18:00 (GMT)
commit	87e040fd0f04307534920d0765af6d5878794a98 (patch)
tree	8faa3f12d311d9c1fc205d9c333e2b15da934894
parent	a0ef7474521413c8967559a635e6fdc0d88f1df6 (diff)
tdf#71409: Stop listening to objects going out-of-focus.
This helps eliminate the number of AtkListener objects growing
over time.

Adding Cc: to Kohei Yoshida
Comment 5 Xisco Faulí 2017-03-01 10:09:08 UTC
The problematic commit was reverted today in https://cgit.freedesktop.org/libreoffice/core/commit/?id=10077a06d8f6d08f276f99024528ee31a57390a9
Closing as RESOLVED FIXED