Download it now!
Bug 106097 - Punctuation error when typing English language documents in a traditional Chinese OS environment
Summary: Punctuation error when typing English language documents in a traditional Chi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2017-02-20 11:14 UTC by Terrence
Modified: 2017-07-14 11:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The description of punctuation error. (14.45 KB, application/vnd.oasis.opendocument.text)
2017-02-20 16:06 UTC, Terrence
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence 2017-02-20 11:14:05 UTC
I am a Chinese user, but I also do a lot of English writing.
I use Traditional Chinese interface.
The error is every time when I use English and input " and ', the Writer always show up 』and 」. Those are punctuation used in Chinese.

Please please find the bug, than you very much.

Terrence
Comment 1 Xisco Faulí 2017-02-20 13:57:22 UTC Comment hidden (obsolete)
Comment 2 Terrence 2017-02-20 16:06:41 UTC
Created attachment 131364 [details]
The description of punctuation error.

I think the problem is the punctuation strategy in term of font code. The detail test is in the attached *.odt file.
Comment 3 Alex Thurgood 2017-02-27 07:49:59 UTC
@Terrence : could you provide us with some more information please :

- what language settings do you have system-wide ? 

- which language have you selected in your keyboard settings ?

- since you mention that you use the traditional Chinese interface, have you additionally installed a LibreOffice English language pack ?
Comment 4 Terrence 2017-02-27 10:20:00 UTC
Thank you so much.

Due to my computer knowledge, I might misunderstand your questions. But I still do my best to respond.

Q- what language settings do you have system-wide ? 
A- Chinese.

Q- which language have you selected in your keyboard settings ?
A- US English and Traditional Chinese.

Q- since you mention that you use the traditional Chinese interface, have you additionally installed a LibreOffice English language pack ?
A- Before now, I didn't. Following your tip, I download English package to try, but the situation still happens.

Hope this has responded your further questions.

Terrence

(In reply to Alex Thurgood from comment #3)
> @Terrence : could you provide us with some more information please :
> 
> - what language settings do you have system-wide ? 
> 
> - which language have you selected in your keyboard settings ?
> 
> - since you mention that you use the traditional Chinese interface, have you
> additionally installed a LibreOffice English language pack ?
Comment 5 Buovjaga 2017-03-04 17:21:13 UTC
Does this also happen with version 5.3?
Comment 6 Mark Hung 2017-07-10 16:18:59 UTC
Auto-correct change single quote to corner brackets or white corner brackets ( Unicode 0x300c-0x300e). They are typically to quote Chinese sentences or conversations. I typically type with IME and turn off this option in auto-correct / option / localized options.


I'll suggest to modify the default values of the option ( for zh-TW ). It should either be turned off or be those like in English.
Comment 7 Xisco Faulí 2017-07-13 09:59:15 UTC
Setting Assignee back to default. Please assign it back to yourself if you're still working on this issue
Comment 8 Terrence 2017-07-14 11:29:57 UTC
The problem has been fixed in 5.3.4.2.
(In reply to Buovjaga from comment #5)
> Does this also happen with version 5.3?
Comment 9 Terrence 2017-07-14 11:31:23 UTC
Thanks for all your responses. My problem has been fixed in the version of 5.3.4.2.
Comment 10 Buovjaga 2017-07-14 11:45:10 UTC
Ok great to hear, closing.