Bug Hunting Session
Bug 106133 - Calc Fails To Select Cell When Referencing Another Sheet and That Sheet Has Column/Row Freeze Enabled
Summary: Calc Fails To Select Cell When Referencing Another Sheet and That Sheet Has C...
Status: RESOLVED DUPLICATE of bug 47349
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable
Depends on:
Blocks: Cell-Reference Cell-Freeze
  Show dependency treegraph
 
Reported: 2017-02-22 02:39 UTC by Kevin Suo
Modified: 2018-04-03 22:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (51.17 KB, text/plain)
2017-02-27 10:10 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2017-02-22 02:39:41 UTC
Steps to Reproduce:

1. New Calc with two sheets ("Sheet1" and "Sheet2").

2. Put cursor in Sheet2:B3, then click the "Freeze Columns and Rows" toolbar icon.

3. Put cursor in Sheet2:C4, then try to reference to any cells in Sheet1. (i.e, type in "=", click "Sheet1", then click any cells in Sheet1).

Expected Behaviour:
In step 3, the formula bar should show the cell reference address when you click any cells in Sheet1.

Current Behaviour:
Formula bar is always showing "=" without the cell reference.

It is noted that it works OK when the columns and rows are not frozen in Sheet2.

Version: 5.4.0.0.alpha0+
Build ID: a6c4552e792f6ab20fae83d354b369defd3bb345
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group
Ubuntu 16.04 LTS X64.
Comment 1 Xisco Faulí 2017-02-27 09:02:57 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: eb7b03b052ffe8c2c577b2349987653db6c53f76
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2017-02-26_22:34:18
Locale: en-GB (es_ES); Calc: group

nor

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?
Comment 2 Kevin Suo 2017-02-27 10:10:59 UTC Comment hidden (obsolete)
Comment 3 Kevin Suo 2017-02-27 10:13:04 UTC Comment hidden (obsolete)
Comment 4 Kevin Suo 2017-02-28 10:04:28 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2017-02-28 12:01:02 UTC Comment hidden (obsolete)
Comment 6 Kevin Suo 2017-03-01 00:50:21 UTC Comment hidden (obsolete)
Comment 7 Kevin Suo 2017-03-01 06:53:23 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2017-03-01 06:56:44 UTC Comment hidden (obsolete)
Comment 9 Justin L 2017-03-01 09:40:08 UTC
The phrase "calc is freezing" is unfortunate because that suggests that LO has become completely unresponsive (i.e. crashed).  Instead, in this case OP simply means that a click is not "registering" and auto-filling the cell reference in the formula bar.

I can reproduce this in LO 5.0 (bibisect50max).  I can reproduce this under windows with LO 5.1.6.2. Because it also fails in Windows, it cannot have any direct relation to the Unix GTK code change as suggested in comment 7.

I'll do some more intensive bibisecting later...
Comment 10 Buovjaga 2017-03-01 09:51:27 UTC
Kevin: could you create a new report for your crashing problem? You can reference to the backtrace as attachment 131503 [details]
Comment 11 Kevin Suo 2017-03-01 10:08:00 UTC Comment hidden (obsolete)
Comment 12 Justin L 2017-03-01 11:17:50 UTC Comment hidden (obsolete)
Comment 13 Kevin Suo 2017-03-01 11:27:34 UTC Comment hidden (obsolete)
Comment 14 Justin L 2017-03-01 12:45:16 UTC
Confirmed =Sheet bug all the way back to bibisect43all oldest.
Steps to confirm:
1.) open calc
2.) click on the plus to create Sheet 2.
3.) click on cell B3 and freeze row/column
4.) still in cell B3, type '=', click on sheet1, and click any cell.

Notice that the formula bar does not insert Sheet1.<cell> when the sheet2 cell is in the non-frozen range.  (It works for cells in the frozen range, and works when freeze row/column is not active.)

Resetting the fields to indicate the description's bug is likely inherited from AOO.
Comment 15 Holger Klene 2018-04-03 22:27:48 UTC
duplicate of #47349 ?

*** This bug has been marked as a duplicate of bug 47349 ***