Download it now!
Bug 106171 - Notebookbar: Drop down actions item size
Summary: Notebookbar: Drop down actions item size
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2017-02-24 10:06 UTC by andreas_k
Modified: 2017-02-27 08:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2017-02-24 10:06:57 UTC
how can the icon size be defined for drop down actions (now only sc_ (16px) icons were used) e.g. color icons 

https://dl.dropboxusercontent.com/u/1642456/LibreOffice/Sizing.png

for now NO notebook-toolbar has the functionality to use drop down actions in another size than sc_
Comment 1 Maxim Monastirsky 2017-02-25 19:01:20 UTC
Did you try to set the "Icon size" property in Glade (under the "General" tab)? It should support the following values:

- small icons (16px), set in Glade with "Menu" or "Small Toolbar".
- large icons (26px), set in Glade with "Large Toolbar".
- extra large (32px), set in Glade with "Drag & Drop".
- default depends on what was set in Tools > Options... for Sidebar/Notebookbar.

I implemented it some time ago with https://cgit.freedesktop.org/libreoffice/core/commit/?id=cdf4b2bba8d694299c784f46fe3ecef2ce41171e (see the commit message for more supported stuff).

In addition, it's possible to set the size of a button regardless of the icon size with "Height request"/"Width request" (under the "Common" tab), but it works only for an individual button, not for a whole toolbar control.
Comment 2 andreas_k 2017-02-25 20:55:00 UTC
Down there is the code of the SetOutline DropDown Button and when I add icon_size it didn't work. Sorry any idea?

<child>
   <object class="GtkToolButton" id="SetOutline">
     <property name="visible">True</property>
     <property name="can_focus">False</property>
     <property name="is_important">True</property>
     <property name="action_name">.uno:SetOutline</property>
     <property name="use_underline">True</property>
   </object>
   <packing>
     <property name="expand">False</property>
     <property name="homogeneous">True</property>
   </packing>
</child>
Comment 3 Maxim Monastirsky 2017-02-25 21:08:35 UTC
(In reply to andreas_k from comment #2)
> Down there is the code of the SetOutline DropDown Button and when I add
> icon_size it didn't work. Sorry any idea?
icon_size belongs to the whole toolbar control (sfxlo-SidebarToolBox or sfxlo-NotebookbarToolBox), not to an individual button. The notebookbar.ui of Writer has some examples of its usage. Also make sure you use a recent version of master which has my commit. And if you're going to use Glade, also make sure to use the Glade catalog from master, not the one from 5.3.
Comment 4 Heiko Tietze 2017-02-26 20:58:43 UTC
Looks like this is not a bug.
Comment 5 andreas_k 2017-02-26 21:44:15 UTC
This is awesome it works. Yes the bug is solved.

But I have two questions:

1. the default icon size for "my" notebookbar_groups.ui file should be Large Toolbar, but I'd like to respect the user settings in Tools > Options how I have to define the icon in the .ui file, cause ordinary I'll say use cmd/lc_xxx file.

2. Is there a GOOD reason why there are 3 settings for the icon size. From my point of view one option should be enough Icon size (Small, Large, Extra Large).
Comment 6 Maxim Monastirsky 2017-02-26 22:05:48 UTC
(In reply to andreas_k from comment #5)
> 1. the default icon size for "my" notebookbar_groups.ui file should be Large
> Toolbar, but I'd like to respect the user settings in Tools > Options
You can't. "Automatic" is currently hardcoded as small.

> 2. Is there a GOOD reason why there are 3 settings for the icon size.
Which 3 settings? I don't understand.
Comment 7 andreas_k 2017-02-27 08:46:40 UTC
> > 2. Is there a GOOD reason why there are 3 settings for the icon size.
> Which 3 settings? I don't understand.

the user can change the toolbar icon size, sidebar icon size and notebook icon size. from my point of view one icon size would be enough.