Download it now!
Bug 106239 - Simplify insertion of page number (enhancement)
Summary: Simplify insertion of page number (enhancement)
Status: RESOLVED DUPLICATE of bug 86630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2017-02-28 17:34 UTC by mr.Pablo
Modified: 2017-03-02 10:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mr.Pablo 2017-02-28 17:34:02 UTC
At the moment, we need the following 3 steps to insert a page number:

1-Insert -> Heather and Footer -> Footer -> Default style

2-Insert -> Field -> Page number

3-Then, optionally but probably, click 'right-align' or 'center-align'.


Possible solution: This task pipeline could be easily simplified down to a single stage, without loss of generality:

1-Insert -> Field -> Page number -> Bottom -> Right

Where, in this case, the page number would be added to the botton right corner of the page (the footer would be automatically added).
Comment 1 mr.Pablo 2017-02-28 17:36:48 UTC
or even Insert -> Page number -> Bottom -> Right
Comment 2 mr.Pablo 2017-03-01 10:20:37 UTC
The 'Insert -> Page number' menu already exists. All it would take would be to create the options for the 'Insert -> Page number -> Bottom -> Right'. In this way, the user could choose to add the page numbers on the right/left/center of the Top(Header) or Bottom(Footer) of the page.
Comment 3 Heiko Tietze 2017-03-02 00:20:32 UTC
Left click somewhere at the bottom in order to get the blue quick add tab. There you can click the + symbol to actually add the footer, and finally insert the page number and format it as you like.

Automatically insert at the footer is a WONTFIX because users may want to add the page number to the header, which would double your left/center/right idea, but also at any place within the current paragraph.
Comment 4 mr.Pablo 2017-03-02 09:33:03 UTC
No, it would not double the idea. If users may want to add the page number to the header, the procedure would be:

Insert -> Page number -> Top -> Right
Comment 5 mr.Pablo 2017-03-02 10:05:02 UTC
If users wanted to add the page number anywhere else on the page, it would be:

Insert -> Page number -> Current Position -> Right


In my opinion, this procedure would make page numbering attribution a lot more intuitive and clearer.
Comment 6 Yousuf Philips (jay) (retired) 2017-03-02 10:07:23 UTC
I've suggested this same enhancement, so lets close this as a duplicate.

*** This bug has been marked as a duplicate of bug 86630 ***
Comment 7 mr.Pablo 2017-03-02 10:21:23 UTC Comment hidden (no-value)