Bug 106271 - Cannot disable Menubar under Unity
Summary: Cannot disable Menubar under Unity
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.2
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-02 08:01 UTC by Samuel Mehrbrodt (CIB)
Modified: 2017-03-15 07:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Macro to hide the menubar (240 bytes, text/plain)
2017-03-02 08:01 UTC, Samuel Mehrbrodt (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2017-03-02 08:01:17 UTC
The attached Macro hides the menubar.

However, this does not work with the Unity Global Menu.

The Unity Menu should be disabled when calling that Macro.
Comment 1 Samuel Mehrbrodt (CIB) 2017-03-02 08:01:54 UTC
Created attachment 131571 [details]
Macro to hide the menubar
Comment 2 Cor Nouws 2017-03-02 09:46:43 UTC
Does work for me in Version: 5.4.0.0.alpha0+
Build ID: 08750abc64a7ad82cac96adeb7a0bcdce7ac704d
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-02-28_00:23:27
Locale: nl-NL (nl_NL.UTF-8); Calc: group

And does not work in Versie: 5.2.2.2 
Build ID: 1:5.2.2-0ubuntu2
CPU Threads: 4; Versie besturingssysteem:Linux 4.8; UI Render: standaard; 
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 3 Samuel Mehrbrodt (CIB) 2017-03-02 10:46:45 UTC
(In reply to Cor Nouws from comment #2)
> Does work for me in Version: 5.4.0.0.alpha0+
> Build ID: 08750abc64a7ad82cac96adeb7a0bcdce7ac704d

Weird, for me in 9a39b4c946f59981975d3cd4556185168192874b (newer than yours) it does not work.
Comment 4 Samuel Mehrbrodt (CIB) 2017-03-02 10:55:41 UTC
Talked with Cor, his build was without Unity integration.

So the problem is still there in master.
Comment 5 Commit Notification 2017-03-06 09:36:07 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2fa5951bf3d02439a3e96d1f9d89962f0901edc

tdf#106271 Cannot disable Menubar under Unity

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-03-14 17:01:48 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=449733a5c3b59c7b56db1db3dbc7fd0dcefd1a55&h=libreoffice-5-3

tdf#106271 Cannot disable Menubar under Unity

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Björn Michaelsen 2017-03-14 23:41:11 UTC
Just a note from the sideline: Disabling the Unity menu is a bad idea anyway, as other stuff, e.g. the H.U.D. depend on the exported gmenumodel.
Comment 8 Samuel Mehrbrodt (CIB) 2017-03-15 07:45:30 UTC
(In reply to Björn Michaelsen from comment #7)
> Just a note from the sideline: Disabling the Unity menu is a bad idea
> anyway, as other stuff, e.g. the H.U.D. depend on the exported gmenumodel.

Right, and it should not be disabled by Joe Average.
But the specific use case we have is that as a Form creator, you want to disable all UI (Menu, Toolbar, Statusbar) to prevent users from doing anything else than filling the form.
In this case we want neither the global menu, nor the HUD.