Bug 106339 - diagrams / textboxes misplaced, missing text (Fileopen regression per comment 15)
Summary: diagrams / textboxes misplaced, missing text (Fileopen regression per comment...
Status: RESOLVED DUPLICATE of bug 138782
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: compatibilityMode15
Keywords: bibisected, bisected, filter:docx
: 106338 (view as bug list)
Depends on:
Blocks: DOCX-compatibilityMode-15
  Show dependency treegraph
 
Reported: 2017-03-05 15:39 UTC by ghavamikia
Modified: 2021-05-05 07:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO ODT (159.71 KB, image/png)
2017-03-05 15:40 UTC, ghavamikia
Details
LO DOCX (176.72 KB, image/png)
2017-03-05 15:40 UTC, ghavamikia
Details
windows (198.83 KB, image/png)
2017-03-05 15:41 UTC, ghavamikia
Details
docx file (408.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-29 12:07 UTC, ghavamikia
Details
odt (366.88 KB, application/vnd.oasis.opendocument.text)
2017-07-29 12:08 UTC, ghavamikia
Details
LO6 (49.18 KB, image/png)
2017-07-29 13:10 UTC, raal
Details
word2010 (31.34 KB, image/png)
2017-07-29 13:10 UTC, raal
Details
docx file compared MSO LO (386.58 KB, image/png)
2020-10-29 09:12 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ghavamikia 2017-03-05 15:39:35 UTC
Here in screenshots is an interesting distinction between original word .docx 2016 flow diagram and the two libreoffice versions of this, one saved as .docx the other .odt (seen on upper taskbar), I thought it was interesting the two outcomes and to inform you guys, any help with fixing this issue?
Comment 1 ghavamikia 2017-03-05 15:40:23 UTC
Created attachment 131649 [details]
LO ODT
Comment 2 ghavamikia 2017-03-05 15:40:42 UTC
Created attachment 131650 [details]
LO DOCX
Comment 3 ghavamikia 2017-03-05 15:41:04 UTC
Created attachment 131651 [details]
windows
Comment 4 Xisco Faulí 2017-03-05 16:24:54 UTC
*** Bug 106338 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2017-03-05 16:26:03 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2017-03-05 20:12:53 UTC
Could you please perform the test the opposite direction. 

That is Save-as from MS Word to an ODF Open Document Text.odt document. Then open that into LibreOffice Writer. Better fidelity? Save and reopen either Word or Writer.
Comment 7 ghavamikia 2017-07-29 12:07:46 UTC
Created attachment 134969 [details]
docx file
Comment 8 ghavamikia 2017-07-29 12:08:19 UTC Comment hidden (obsolete)
Comment 9 ghavamikia 2017-07-29 12:10:39 UTC
Thank you for your help, I have attached the vector diagram with picture and text, created in the latest MS Word and saved in both ODT and DOCX format, there are still issues opening these in the latest 5.4 LO release. I hope this helps.
Comment 10 raal 2017-07-29 13:10:29 UTC
Created attachment 134972 [details]
LO6

FAHR CASE docx.docx:  tested with LO6 and looks good compared to your printscreen. Only issue I see here are black boxes -  I doesn't see text in LO, and misplaced textboxes. When I open your file in word2010, the result is worse then in LO.
Comment 11 raal 2017-07-29 13:10:52 UTC
Created attachment 134973 [details]
word2010
Comment 12 ghavamikia 2017-07-29 13:31:55 UTC
Thank you for your speedy reply. 

Please could you see the 3rd attachement as the reference image here. The inclusion of Word 2010 is intersting, it makes me think LO is more interoperable in this field with that gerenation of MSoffice products, which is interesting in it's own right I suppose, but not entirely relevant to this particular problem.

The vector image was created with Word 2016, and that is attached as the reference image above under "windows" (3rd attchment). 

With regards LO6, I believe you're opening the docx file and this is no improvement over the prior 5.3 release's handling of the docx saved file, attached as a screenshot above (2nd attachement) "LO DOCX". 
Issues, apart from the text you mentioned, are misplaced arrows. Again I ask you refer to the MS 2016 and not 2010 as the reference. 

Of note, there has been improvement with the rendering of the ODT saved format of the same,  from 5.4 (not attached, as you can generate yourself) in comparison to 5.3 (attched, 1st attachement), however it is still poor. 

I hope this information is helpful
Comment 13 QA Administrators 2019-02-06 03:50:35 UTC Comment hidden (obsolete)
Comment 14 Timur 2020-10-29 09:12:04 UTC
Created attachment 166835 [details]
docx file compared MSO LO

This bug is wrong on all accounts. It started as Filesave but it makes no sense because Fileopen is wrong. Also, this is document-based bug but should be issue-based. 

For attachment 134969 [details] MSO docx I add screenshot with 3 fileopen issues:
1. text box shape wrong position, regression from 6.0
2. images wrong position, regression from 6.1
3. 1-page opens as 3-page, same as 2.
Comment 15 Timur 2020-10-29 09:48:20 UTC
Let this bug be about fileopen of 1 page with images position, per following bibisect in 6.1 Linux. Miklos, please take a look. 
I opened bug 137850 for text box shape regression. 

commit d3a9de0f5a9f06441f45231727fede6a986d122c
Date:   Wed Feb 14 21:17:20 2018 +0100
    source 8b73bafbc18acb4dd8911d2f2de8158d98eb6144
    prev source b13678b1e1d6f4cac548ae7e088b6030c31cf081

author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-02-14 15:31:35 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-02-14 20:21:57 +0100
commit 8b73bafbc18acb4dd8911d2f2de8158d98eb6144 (patch)
tree 5bb43213b1c7ef8802d8f6b50bffdf9742117ad2
parent b13678b1e1d6f4cac548ae7e088b6030c31cf081 (diff)
tdf#115719 DOCX import: increase paragraph spacing for anchored objects

Once all resolved, new bug should be open for single issue in filesave, tested both for ODT and DOC and DOCX, only if not found existing. 
No need to attach resulting documents, source is enough. Instead, screenshot comparison is advised.
Comment 16 Justin L 2020-10-30 11:03:28 UTC
Comment 10 is extremely important.
Any attempt to fix this bug must not break documents using an older compatibilityMode than 15. See attachment 166871 [details] for a compatibilityMode = 11 version of this document (from related bug 137850).
Comment 17 Justin L 2020-10-30 11:12:56 UTC
Adding NISZ team to the CC.
I know you guys have been doing a lot of work related to shapes/positioning. If you aren't aware that compatibilityMode can significantly affect that, then this document is a great proof example that it certainly does. So I hope you always keep that in mind as you work on more position stuff.

compare comment 3's Word2016 screenshot with comment 11's Word2010 screenshot.
Comment 18 Attila Bakos (NISZ) 2021-05-05 06:27:26 UTC

*** This bug has been marked as a duplicate of bug 138782 ***