Download it now!
Bug 106341 - Presentation mode glitches at canvas size > 2048 px
Summary: Presentation mode glitches at canvas size > 2048 px
Status: RESOLVED DUPLICATE of bug 40534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2017-03-05 16:57 UTC by Johannes
Modified: 2018-03-21 04:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
fullscreen.png (1.68 MB, image/png)
2017-03-05 16:57 UTC, Johannes
Details
windowed.jpg (523.23 KB, image/jpeg)
2017-03-05 16:58 UTC, Johannes
Details
fullscreen.jpg (184.23 KB, image/jpeg)
2017-03-05 16:58 UTC, Johannes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes 2017-03-05 16:57:24 UTC
Created attachment 131654 [details]
fullscreen.png

to reproduce:
1. have a 2560x1440 monitor (or somehow set your screen resolution to something higher than 2048 in width)
2. enter presentation mode
3. Go through some slides
4. notice how it doesn't work. The center area is not updated at all, whereas two bars on the left and right still get updated (see attached fullscreen.png)

When enabling windowed presentation mode and changing the window's size from small to large, it becomes apparent that as soon as the presentation area exceeds a width of 2048, it gets filled with some artifacts and then never updates again when changing slides (see attached windowed.png)

i'm pretty sure this already happened with 5.1.
Comment 1 Johannes 2017-03-05 16:58:09 UTC
Created attachment 131655 [details]
windowed.jpg
Comment 2 Johannes 2017-03-05 16:58:47 UTC
Created attachment 131656 [details]
fullscreen.jpg
Comment 3 Johannes 2017-03-06 14:26:31 UTC
had the chance to test this out on a friend's laptop with a hi res display, and there it just worked. i can't say what the differences were, i used the same libreoffice version, and both were windows 10. however, although the laptop had an nvidia card, the intel chip might've been active.
Comment 4 Harald Bopp 2017-08-02 06:53:06 UTC
I do observe the same strange behavior on my new HP Elitebook with 2560x1440 resolution in presentation mode.

Reducing the resolution to 1920x1200, presentation works fine again.

OS: Win7, 64Bit, Enterprise Ed. (Ultimate)
LibreOffice: Vers. 5.[234].*
Comment 5 Timur 2017-08-02 07:35:11 UTC
I don't have that laptop (unfortunately :)) but this was confirmed by Harald so I set to New.
As for "i'm pretty sure this already happened with 5.1." please:
- get http://tdf.io/siguiexe to easily get and run "parallel" LO in Windows (extract without installation)
- run different extracted LO versions (like oldest, 5.1 and master) and architectures (32-bit or 64-bit) in order to test
- try changing Tools-Options-View-Graphic Output options and note what you conclude (is it related to hw accleleration, anti-aliasing, OpenGL).
Comment 6 V Stuart Foote 2018-03-21 04:32:45 UTC
On a 4K (3840 x 2160) monitor, STR shows screen tearing when Hardware Acceleration rendering is enabled. Disabling HA, or enabling OpenGL rendering clears issue and the presentation is rendered. 

On this monitor, Left/Right gullies show black at 4:3 presentation, and a 16:9 presentation shows full screen.

Resolving this duplicate of bug 40534 - slide tearing or not shown in LARGE screens (high resolution) with hardware acceleration enabled.

*** This bug has been marked as a duplicate of bug 40534 ***