Download it now!
Bug 106345 - In search of a better name for last line justification
Summary: In search of a better name for last line justification
Status: RESOLVED DUPLICATE of bug 98211
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Paragraph-Alignment
  Show dependency treegraph
 
Reported: 2017-03-05 22:22 UTC by Munzir Taha
Modified: 2017-12-18 12:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2017-03-05 22:22:04 UTC
Description:
Format -> Paragraph -> Alignment -> Justified -> Last Line: left
The word left here is correct in left to right languages but in RTL it works as right. The current functionality is correct but the name is misleading. I suggest changing it to something like "start" or as scribus use of "justified" and "force justfied" for the two modes if you wish.

Steps to Reproduce:
Format -> Paragraph

Actual Results:  
It shows "left"

Expected Results:
Should show "start"


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 V Stuart Foote 2017-03-06 15:19:33 UTC
The actual VCL formatting to canvas follows the RTL - LTR sense of the script/language locale in use for the paragraph.

So this is only a cosmetic labeling issue. 

But--with so many locations in the UI with "Left" label actually representing the "Start" position in LTR or RTL, equally for TTB (or even BTT should that ever be implemented)--rather than doing it piecemeal one GUI element at a time it needs a more complete UX review on how to correct.
Comment 2 Heiko Tietze 2017-03-06 20:47:47 UTC
"Start" might be confusing. "Left/Right" could work and of course a simple "Left" or "Right" depending on LTR vs. RTL. And if all fails why not have a right aligned last line even for LTR?

Taking 'Text direction' in the same dialog into account and the fact that independently from this setting Left always means left in the preview I'm afraid that RTL is not respected anyway.
Comment 3 LibreTraining 2017-03-06 22:17:40 UTC
- Align Left
and
- Align Right

These match the labels on the icons for paragraph alignment on the toolbar.
Same terms. Same effect.
Introducing new terms for the same thing would just be confusing.



And while we are at it ..

- Align horizontally  (on the toolbar icon)
is inconsistent with other labels.
In the style dialogs this is “Centered” which makes more sense.

- Align center
would be a better and more consistent label.

Which term does not belong?
- Left
- Right
- Center
- Horizontal

Alignment: Left/Center/Right
Direction: Horizontal/Vertical



Microsoft Word – labels include:
- Align Left
- Align Center
- Align Right
- Justified

Word just defaults to Align Left for the last line of Justified text (in LTR languages).


Adobe InDesign – labels include:
- Align left
- Align center
- Align right
- Justify with last line aligned left
- Justify with last line aligned center
- Justify with last line aligned right
- Justify all lines
- Align towards spine
- Align away from spine


.
Comment 4 Adolfo Jayme 2017-07-09 01:16:42 UTC
What about “Absolute justification”?
Comment 5 Yousuf Philips (jay) (retired) 2017-12-18 12:38:45 UTC

*** This bug has been marked as a duplicate of bug 98211 ***