Bug 106363 - sidebar no remembering user setting to not show
Summary: sidebar no remembering user setting to not show
Status: RESOLVED DUPLICATE of bug 67770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-03-06 15:53 UTC by steve -_-
Modified: 2017-03-07 02:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steve -_- 2017-03-06 15:53:30 UTC
Description:
sidebar shows in master. is hidden but re-appears on next open of LO master.

Steps to Reproduce:
1. open master lo
2. hide sidebar (untick view > sidebar)
3. re-open LO

Actual Results:  
sidebar is back

Expected Results:
no sidebar


Reproducible: Always

User Profile Reset: No

Additional Info:
I understand: 1 issue per bug, but since it may be related to the same problem, window size is also not remembered.


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 steve -_- 2017-03-06 15:53:51 UTC
adding regression
Comment 2 steve -_- 2017-03-06 15:54:11 UTC
Version: 5.4.0.0.alpha0+
Build ID: c328c26a67a865d965cb8bde1b248eeae92f4e75
CPU threads: 4; OS: Mac OS X 10.12.3; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-03-04_00:50:09
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 3 Alex Thurgood 2017-03-06 17:25:17 UTC
No repro with

Version: 5.4.0.0.alpha0+
Build ID: 6de4ecbe1372c0242f406d45cf999969616f87dc
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.3; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 4 steve -_- 2017-03-06 17:29:04 UTC
Reset user profile, bug persisting.

The bug also affects the ruler (which re-appears after being hidden) and window size.
Comment 5 V Stuart Foote 2017-03-06 22:21:50 UTC

*** This bug has been marked as a duplicate of bug 67770 ***
Comment 6 Aron Budea 2017-03-07 00:42:08 UTC
Stuart, steve -_- also has problems with ruler and window size settings not being kept, it doesn't seem to be the same.

Unfortunately, I couldn't reproduce it with a self-built LibreOffice Linux build from yesterday.
Comment 7 V Stuart Foote 2017-03-07 02:19:42 UTC
On a 5.3.0.3 build on macOS 10.12.3 I see the Siebar deck related stanzas being written to registrymodifications.xcu, but then not asserting on reopening LO.

Not reading/processing them on launch is residual to bug 67770 and the original features for it [1].

And hate to kick it back to Bubli and Laurent, as it could be something specific to macOS, but recording/restoring SideBar state has never worked 100% cross platform.

Same time, issues with the Ruler and Windows size settings are not part of recording states of the Sidebar elements, but they also are recorded into registrymodifications.xcu--although I did not check it while poking at macOS. On the Windows builds they are:

Ruler per module "HorizontalRuler" stanza set true|false

While Window size is by written per module, e.g.
org.openoffice.Setup:Factory['com.sun.star.text.TextDocument']

and then duplicated to the StartModule if last closed
org.openoffice.Setup:Factory['com.sun.star.frame.StartModule']


=-ref-=
[1] https://gerrit.libreoffice.org/#/c/17992/