Bug 106368 - Android: restrict zoom to page width
Summary: Android: restrict zoom to page width
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium minor
Assignee: Ximeng Zu
URL:
Whiteboard: target:5.4.0
Keywords:
: 89919 (view as bug list)
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2017-03-06 19:54 UTC by Tomaz Vajngerl
Modified: 2017-09-06 21:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomaz Vajngerl 2017-03-06 19:54:06 UTC
Description:
When zooming (with pinch to zoom) don't allow to zoom to a factor smaller than page width (this restriction doesn't apply for Calc). 

Steps to Reproduce:
.

Actual Results:  
.

Expected Results:
.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Ximeng Zu 2017-03-13 03:45:39 UTC
I'd like to work on this issue. I think it would be better to have a setting to limit zoom or not as well.
Comment 2 Tomaz Vajngerl 2017-03-13 10:28:49 UTC
Sure, let's see what you come up with. It shouldn't be too hard once you find the correct place.
Comment 3 Ximeng Zu 2017-03-23 03:32:22 UTC
(In reply to Tomaz Vajngerl from comment #2)
> Sure, let's see what you come up with. It shouldn't be too hard once you
> find the correct place.

I submitted a patch couple of days ago and I guess it's still under review.
For a quick question, why the zoom restriction shouldn't apply to Calc?
How is it supposed to be for Calc...?
Comment 4 Tomaz Vajngerl 2017-03-23 09:11:30 UTC
I'm not monitoring gerrit and you didn't put me as a reviewer or said anything here, so I didn't know that you submitted a patch.

Why not calc - because in calc the current range is "the document" so it makes no sense to restrict zoom there. Calc needs special UI and handling anyway and that is a much larger task that needs to be done separately to this.
Comment 5 Ximeng Zu 2017-03-23 17:23:42 UTC
(In reply to Tomaz Vajngerl from comment #4)
> I'm not monitoring gerrit and you didn't put me as a reviewer or said
> anything here, so I didn't know that you submitted a patch.
> 
> Why not calc - because in calc the current range is "the document" so it
> makes no sense to restrict zoom there. Calc needs special UI and handling
> anyway and that is a much larger task that needs to be done separately to
> this.

I should have familiarized myself with gerrit and bugzilla and their linkage..
I went and added you as a reviewer and will let you know about my future
patches. Also the link is: https://gerrit.libreoffice.org/#/c/35308/

For Calc, I didn't single it out for in my patch. I guess it can wait till the special UI comes out. 

Thanks for the help!
Comment 6 Tomaz Vajngerl 2017-03-23 19:13:06 UTC
Yeah, it is OK to not single it out for Calc. 

You're working on a next bug?
Comment 7 Ximeng Zu 2017-03-23 23:21:13 UTC
(In reply to Tomaz Vajngerl from comment #6)
> Yeah, it is OK to not single it out for Calc. 
> 
> You're working on a next bug?

Yea I'm trying to look into this bug Bug 96816.
Comment 8 Commit Notification 2017-04-18 11:05:21 UTC
Ximeng Zu committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed900113d091431f89ccc312b55a6955ca341b9e

tdf#106368 android: restrict zoom to page width

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2017-06-09 09:57:39 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 10 Ximeng Zu 2017-06-09 14:50:57 UTC
Also see this patch with an update of the bug fix.
Comment 11 Ximeng Zu 2017-06-09 14:51:19 UTC
(In reply to Ximeng Zu from comment #10)
> Also see this patch with an update of the bug fix.

https://gerrit.libreoffice.org/#/c/37847/
Comment 12 Christian Lohmaier 2017-09-06 21:25:18 UTC
*** Bug 89919 has been marked as a duplicate of this bug. ***