Bug Hunting Session
Bug 106415 - wrong rendering embedded image in PNG format if OpenGL enabled (windows) and disabled (Linux)
Summary: wrong rendering embedded image in PNG format if OpenGL enabled (windows) and ...
Status: RESOLVED DUPLICATE of bug 86675
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2017-03-07 19:36 UTC by Roman Kuznetsov
Modified: 2018-01-28 04:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODT file with problem image (784.46 KB, application/vnd.oasis.opendocument.text)
2017-03-07 19:37 UTC, Roman Kuznetsov
Details
screenshot of wrong image rendering (windows) (61.53 KB, image/png)
2017-03-07 19:38 UTC, Roman Kuznetsov
Details
screenshot of good image rendering after export to PDF (in PDF, windows) (141.46 KB, image/png)
2017-03-07 19:39 UTC, Roman Kuznetsov
Details
screenshot of wrong image rendering (linux, xUbuntu) (76.16 KB, image/png)
2017-03-07 19:40 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-03-07 19:36:33 UTC
Description:
wrong rendering embedded image in PNG format (see attaches), but after export to PDF image looks well (normal). So:
1. In windows 7 - OpenGL enabled -> image looks badly -> export in PDF and in PDF this image is OK -> LibreOffice image rendering problem (IMHO)
2. In windows 7 - OpenGL disabled -> image looks OK 
3. In Linux (xUbuntu 16.04) - OpenGL disabled -> image looks badly!

Steps to Reproduce:
1. Open file from attach 
2. Activate OpenGL in Tools-Options-LibreOffice-View
3. See on screen

Actual Results:  
image is wrong rendering

Expected Results:
image is normal look


Reproducible: Always

User Profile Reset: No

Additional Info:
opengl_device.log

DriverVersion: 15.200.1062.1004
DriverDate: 8-3-2015
DeviceID: PCI\VEN_1002&DEV_6779&SUBSYS_03DA1043&REV_00
AdapterVendorID: 0x1002
AdapterDeviceID: 0x6779
AdapterSubsysID: 0x03da1043
DeviceKey: System\CurrentControlSet\Control\Video\{72FA7661-26BE-4A7C-B473-0F288EEB349A}\0000
DeviceString: AMD Radeon HD 6450


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Roman Kuznetsov 2017-03-07 19:37:31 UTC
Created attachment 131724 [details]
ODT file with problem image
Comment 2 Roman Kuznetsov 2017-03-07 19:38:48 UTC
Created attachment 131725 [details]
screenshot of wrong image rendering (windows)
Comment 3 Roman Kuznetsov 2017-03-07 19:39:54 UTC
Created attachment 131726 [details]
screenshot of good image rendering after export to PDF (in PDF, windows)
Comment 4 Roman Kuznetsov 2017-03-07 19:40:29 UTC
Created attachment 131727 [details]
screenshot of wrong image rendering (linux, xUbuntu)
Comment 5 Roman Kuznetsov 2017-03-07 19:41:23 UTC
and, if OpenGL is disabled then image is looking OK on Windows
Comment 6 Buovjaga 2017-03-11 20:24:16 UTC

*** This bug has been marked as a duplicate of bug 86675 ***