Bug 106452 - Impress: Characters in a text have incorrect spacing, overlap one another
Summary: Impress: Characters in a text have incorrect spacing, overlap one another
Status: RESOLVED DUPLICATE of bug 103831
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.1.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-03-09 11:07 UTC by Roman Kuznetsov
Modified: 2018-01-28 04:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
file of presentation (64.56 KB, application/vnd.oasis.opendocument.presentation)
2017-03-09 11:08 UTC, Roman Kuznetsov
Details
screenshot with wrong spacing in text (26.23 KB, image/png)
2017-03-09 11:10 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2017-03-09 11:07:34 UTC
Description:
Impress: Characters in a text have incorrect spacing, overlap one another
see screeenshot in attach

LO 5.3.1.1 on Windows 7

Steps to Reproduce:
1. Open file from attach
2. Select second (or any except first) slide on Slide Pane
3. See on text of list in slide

Actual Results:  
Characters in a text have incorrect spacing, overlap one another

Expected Results:
normal spacing in text


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Roman Kuznetsov 2017-03-09 11:08:22 UTC
Created attachment 131770 [details]
file of presentation
Comment 2 Roman Kuznetsov 2017-03-09 11:10:07 UTC
Created attachment 131771 [details]
screenshot with wrong spacing in text
Comment 3 Xisco Faulí 2017-03-09 11:47:16 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2017-03-09 12:02:02 UTC
i dropped my user profile, bug is still reproduce
Comment 5 V Stuart Foote 2017-03-09 13:37:51 UTC
Confirmed on Windows 10 Pro 64-bit en-US with OpenGL rendering enabled, text scaling issue of bug 103831, it scales correctly with Default rendering.

Version: 5.3.1.1 (x64)
Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

however this was just corrected on 5.3 with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=4375eefb644d03ab4bafbc091436166a8494dc91&h=libreoffice-5-3

The presentation renders correctly with

Version: 5.3.2.0.0+
Build ID: a990b46ccc788db45ff4d8f0d47b799782ecb2af
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-03-08_19:18:26
Locale: en-US (en_US); Calc: CL

*** This bug has been marked as a duplicate of bug 103831 ***
Comment 6 Roman Kuznetsov 2017-03-09 14:50:39 UTC
(In reply to V Stuart Foote from comment #5)
> Confirmed on Windows 10 Pro 64-bit en-US with OpenGL rendering enabled, text
> scaling issue of bug 103831, it scales correctly with Default rendering.
> 
> Version: 5.3.1.1 (x64)
> Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
> CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
> Locale: en-US (en_US); Calc: group
> 

of course! i have enabled OpenGL accidentally! =(

> however this was just corrected on 5.3 with
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=4375eefb644d03ab4bafbc091436166a8494dc91&h=libreoffice-5-3
> 
> The presentation renders correctly with
> 
> Version: 5.3.2.0.0+
> Build ID: a990b46ccc788db45ff4d8f0d47b799782ecb2af
> CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
> TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time:
> 2017-03-08_19:18:26
> Locale: en-US (en_US); Calc: CL
> 
> *** This bug has been marked as a duplicate of bug 103831 ***
Comment 7 V Stuart Foote 2017-03-09 15:12:55 UTC
(In reply to kompilainenn from comment #6)
> 
> of course! i have enabled OpenGL accidentally! =(
> 

No worries! But be sure to check out a 5.3.2 build with OpenGL enabled 5.3.2, or master when the TBs are moved to VS2015. 

Khaled's refactoring to replace the DirectWrite calls for font scaling and non-horizontal shaping with GDI has removed some major deficiencies in the OpenGL rendering.

It is not the final solution of course because for OpenGL we really should move everything to DirectWrite rather than GDI+. But as I understand things, the DirectWrite implementation has to be refactored to fully correct its function.

So mixing in GDI calls is a "temporary" necessity.