Bug 106487 - cell colors dissappear while editting formula
Summary: cell colors dissappear while editting formula
Status: RESOLVED DUPLICATE of bug 38304
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2017-03-10 23:25 UTC by Severo Raz
Modified: 2017-03-15 11:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

file to demonstrate the bug (7.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-03-11 13:37 UTC, Severo Raz
same document modified (8.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-03-11 14:36 UTC, Jacques Guilleron

Note You need to log in before you can comment on or make changes to this bug.
Description Severo Raz 2017-03-10 23:25:59 UTC
In the formula of a cell which refers to other cells, the colors assigned to the referred cells become black when the formula is being edited.

It would be expected that the colors remain, since they can prove to be of great visual aid and improve the formula editing process.
Comment 1 Jacques Guilleron 2017-03-11 11:08:10 UTC

Thanks to take time to report this disfunction. Would you be so kind to also provide a document showing the bug?
Comment 2 Severo Raz 2017-03-11 13:37:09 UTC
Created attachment 131813 [details]
file to demonstrate the bug

I have attached a file to demonstrate the bug. 

For those wanting to try this out, it is probably much simpler to reproduce the bug in an empty document than by downloading the file: the file is empty except for a formula in the A1 cell which reads "=A2" (unquoted, of course). Upon editing the formula, adding any character to it will remove the color from the A2 reference.
Comment 3 Jacques Guilleron 2017-03-11 14:36:44 UTC
Created attachment 131814 [details]
same document modified


I wanted to be sure we were speaking about the same thing.
I added only +2 to the formula. No color change into result for me with
LO Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: single

Comment 4 Jacques Guilleron 2017-03-11 14:39:56 UTC
Can you precise which OS you tried?

Thank you,

Comment 5 Severo Raz 2017-03-11 18:43:45 UTC
(In reply to Jacques Guilleron from comment #4)
> Can you precise which OS you tried?

Sure, I'm using Arch Linux 4.9.11-1-ARCH, but would this have any effect? Are we using the same version? The problem is only detectable as you actually edit the formula. When you leave and re-enter the formula, you will see the cell reference colors again.
Comment 6 Buovjaga 2017-03-15 11:28:23 UTC

*** This bug has been marked as a duplicate of bug 38304 ***