Bug Hunting Session
Bug 106495 - big gap after letter "v" with font Liberation Sans and font size 10
Summary: big gap after letter "v" with font Liberation Sans and font size 10
Status: RESOLVED DUPLICATE of bug 103322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-03-11 16:02 UTC by Gilward Kukel
Modified: 2017-03-20 20:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
"va" in 5.2.6.2 and in 5.3.0.3 (1.19 KB, image/png)
2017-03-11 16:03 UTC, Gilward Kukel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilward Kukel 2017-03-11 16:02:14 UTC
Description:
There is a big gap after the letter "v" with font Liberation Sans and font size 10.

Steps to Reproduce:
1. In Calc or Writer, set font Liberation Sans and font size 10. That's the default in Calc.
2. Type "va".

Actual Results:  
big gap between "v" and "a"

Expected Results:
smaller gap


Reproducible: Always

User Profile Reset: yes

Additional Info:
It is okay in 5.2.6.2.


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Gilward Kukel 2017-03-11 16:03:43 UTC
Created attachment 131815 [details]
"va" in 5.2.6.2 and in 5.3.0.3
Comment 2 Aron Budea 2017-03-12 01:25:55 UTC
Confirmed in 5.3.1.2 / Windows 7. Doesn't occur if common layout is turned off.
Possibly a duplicate of bug 105454?
Comment 3 V Stuart Foote 2017-03-12 05:43:49 UTC
Can not confirm on windows 10 Pro 64-bit en-US with nVidia GPU and
Version: 5.3.1.1 (x64)
Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL or Default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

The Liberation Sans 10pt pairs of va and VA are consistently spaced.

And with selection the Format -> Character -> Position tab: Pair kerning checkbox has no noticible effect.

Likewise do not see excessive spacing with 5.3.2.0+ build on Windows 10
Version: 5.3.2.0.0+
Build ID: a990b46ccc788db45ff4d8f0d47b799782ecb2af
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-03-08_19:18:26
Locale: en-US (en_US); Calc: CL


So, Windows 7 only?
Comment 4 Johnny_M 2017-03-12 15:48:12 UTC
(In reply to Aron Budea from comment #2)
> Confirmed in 5.3.1.2 / Windows 7. Doesn't occur if common layout is turned
> off.
> Possibly a duplicate of bug 105454?

Or of bug 103322.

(In reply to V Stuart Foote from comment #3)
> [...]
> So, Windows 7 only?

It might depend on the screen resolution, font size and zoom. (The bug reporter states a specific font size.) Judging by the provided screenshot, the tested resolution is rather low, which is where the bug 103322 shines in full glory. And starting from LO 5.3 on all platforms (previously only on Linux).
Comment 5 Gilward Kukel 2017-03-12 16:06:21 UTC
My resolution is 1366 x 768.
Comment 6 Khaled Hosny 2017-03-12 17:01:05 UTC

*** This bug has been marked as a duplicate of bug 103322 ***
Comment 7 DeepFlight5 2017-03-15 07:00:41 UTC Comment hidden (no-value)
Comment 8 DeepFlight5 2017-03-15 07:04:32 UTC Comment hidden (no-value)
Comment 9 Johnny_M 2017-03-20 20:12:49 UTC
(In reply to DeepFlight5 from comment #8)
> (In reply to DeepFlight5 from comment #7)
> > > Judging by the provided screenshot,
> > > the tested resolution is rather low, which is where the bug 103322 shines in
> > > full glory. And starting from LO 5.3 on all platforms (previously only on
> > > Linux).
> > 
> > Who does this decision to "bless" all LO users with a crappy font display,
> > if they know that this new font engine has a mayor display bug? I'm on a Mac
> > and until LO 5.2.6.2 all is beautiful. I tried LO 5.3 when they started to
> > use this "Buzz" engine on all platforms, and now all font displays are
> > destroyed and all my old documents layouts are massively broken and unusable
> > (I publish a newsletter). So I'll stay indefinitely with LO 5.2 since this
> > bug will be with us a very long time.

The unification of layout systems is not a bad thing. Layout display on Mac OS (and Win) has had its own issues. Anyway, you shouldn't use the "fresh" branch of LO, unless you are willing to report issues. The "still" branch is the stable one (the higher its bug-fix version part, the more stable, while supported [1]). If you really need LO 5.3 now, then you could disable the new engine as described here: https://bugs.documentfoundation.org/show_bug.cgi?id=89870#c32 (there most likely won't be a choice in LO 5.4, but there should be fewer issues then as well).
 
> P.S. What I don't understand: LO says that Firefox and Chrome also use this
> "Buzz" engine cross platform for font display. Well, I don't believe it,
> because font display on the Mac is perfectly in Firefox and Chrome. Maybe LO
> uses an old, buggy and inferior version of the "Buzz" engine?

There is no contradiction. Layout engine is just one part responsible for the document display. And apparently more code than just the layout engine has been unified - namely the parts interfacing with it. And that's where this issue lies.

[1] https://wiki.documentfoundation.org/ReleasePlan