Bug 106498 - incorrect display of abs{x} in version 5.3
Summary: incorrect display of abs{x} in version 5.3
Status: RESOLVED DUPLICATE of bug 104509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-03-11 20:38 UTC by Eisso Atzema
Modified: 2017-03-13 13:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example of different display of abs{x} in 5.2.5 vs. 5.3 (14.88 KB, application/vnd.oasis.opendocument.text)
2017-03-11 20:38 UTC, Eisso Atzema
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eisso Atzema 2017-03-11 20:38:19 UTC
Created attachment 131816 [details]
example of different display of abs{x} in 5.2.5 vs. 5.3

Before version 5.3, the equation editor always worked fine for me. With 5.3, however, it seems any formula containing abs{x} (and possibly other expressions) is displayed incorrectly. From what I see, it would appear that only the upper parts of the vertical lines are drawn, or that the lines have moved up. Saving a file with an equation containing abs{x} in 5.3 and then opening the file in an earlier version results in the exact same incorrect representation. However, opening the equation with abs{x} with the equation editor of the earlier version fixes the problem. Likewise, a file with abs{x} created  in an earlier version of LO displays correctly in 5.3 until the equation with abs{x} is opened with the equation editor of version 5.3, after which abs{x} is displayed incorrectly again.
Comment 1 Xisco Faulí 2017-03-12 16:33:16 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: d3b5bd4a07a619db6bee1c39c32280ac3c620532
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Alex Thurgood 2017-03-13 07:20:25 UTC
Probably a harfbuzz/coretext problem specific to MacOS like the other mispositioned character bug reports.
Comment 3 Alex Thurgood 2017-03-13 07:34:41 UTC
Confirming

Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.3; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 4 Alex Thurgood 2017-03-13 07:35:34 UTC
@Khaled : one for you ?
Comment 5 خالد حسني 2017-03-13 13:14:12 UTC
Should be already fixed in master and 5.3.1, please reopen if it is not the case.

*** This bug has been marked as a duplicate of bug 104509 ***