Bug Hunting Session
Bug 106527 - Completely support BASE table
Summary: Completely support BASE table
Status: RESOLVED DUPLICATE of bug 104930
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-03-14 08:10 UTC by Volga
Modified: 2017-04-08 01:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-03-14 08:10:14 UTC
Description:
The Baseline table (BASE) can be used to align glyphs for multilingual texts, with this support we can make LibreOffice well performanced for vertical alignment for horizontal text, or horizontal alignment for vertical text.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
-


Reproducible: Always

User Profile Reset: No

Additional Info:
For more details of this table, see:
https://www.microsoft.com/typography/otspec/baselinetags.htm


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Elie Roux 2017-03-14 10:56:01 UTC
Well, I think it could be merged with https://bugs.documentfoundation.org/show_bug.cgi?id=104930 but that's a better title. Anyways, to fully support the different baselines, users should be able to manually set the different baselines at character, line or paragraph level (although a reasonable automatic guess could be implemented first). Having these baseline options not only means UI but also modifications in the file format, providing extensions to ODF, etc. that's quite a big job...
Comment 2 Buovjaga 2017-03-16 08:16:10 UTC

*** This bug has been marked as a duplicate of bug 104930 ***
Comment 3 Volga 2017-04-08 01:53:16 UTC
(In reply to Elie Roux from comment #1)
Anyways, to fully support the different baselines, users
> should be able to manually set the different baselines at character, line or
> paragraph level (although a reasonable automatic guess could be implemented
> first). Having these baseline options not only means UI but also
> modifications in the file format, providing extensions to ODF, etc. that's
> quite a big job...
We can submitting a proposal to OASIS Technical Committees, then focus on their Issue Tracker if they are decided to do that.