Bug Hunting Session
Bug 106550 - regression: text fields in PPT and PPTX files have insufficient width
Summary: regression: text fields in PPT and PPTX files have insufficient width
Status: RESOLVED DUPLICATE of bug 103831
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-03-15 14:49 UTC by muso
Modified: 2017-03-17 09:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
simple PPT testfile (422.50 KB, application/vnd.ms-powerpoint)
2017-03-15 14:51 UTC, muso
Details
screenshot of the problem (214.54 KB, image/jpeg)
2017-03-15 14:52 UTC, muso
Details
Fixed test file as described in comment 8 (362.00 KB, application/vnd.ms-powerpoint)
2017-03-16 18:52 UTC, muso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2017-03-15 14:49:44 UTC
Description:
Text fields in PPT and PPTX files have zero width in Impress.

This bug is a regression to Impress 5.2.x. It affects PPT and also PPTX files.
This bug makes Impress more ore less unusable and I had therefore downgrade to Impress 5.2.x for daily work.

Steps to Reproduce:
Open a PPT or PPTX file of your choice that has a text field. I also attached a very simple one-slide example PPT file.

Actual Results:  
The text fields have zero width. Therefore all letters of the field are placed upon each other, see the attached screenshot.

Expected Results:
Well, readable text of course.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 muso 2017-03-15 14:51:05 UTC
Created attachment 131903 [details]
simple PPT testfile
Comment 2 muso 2017-03-15 14:52:12 UTC
Created attachment 131904 [details]
screenshot of the problem

The screenshot was taken with LO 5.3.1RC1 (64bit) under Windows 7, 64bit.
Comment 3 Xisco Faulí 2017-03-15 15:08:50 UTC
I can't reproduce it in

Versión: 5.3.1.1
Id. de compilación: 72fee18f394a980128dc111963f2eefb05998eeb
Subpr. de CPU: 1; SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 4 Xisco Faulí 2017-03-15 15:32:29 UTC Comment hidden (obsolete)
Comment 5 muso 2017-03-16 11:11:39 UTC
(In reply to Xisco Faulí from comment #4)
> Could you please try to reset your Libreoffice profile (
> https://wiki.documentfoundation.org/UserProfile ) and re-test?

Dear Xisco,

many thanks for your help. I reset the userprofile but it did not help. I therefore used the radical way: I uninstalled LibreOffice _completely_. Afterwards I run CCleaner and also searched the registry manually. I had nothing left from LibreOffice.

Then I restarted the PC and reinstalled LibreOffice 5.3.1RC1 (64bit). But even then the problem persist. Restarting LibreOffice in safe mode also doesn't change anything. I am still lost. Can't you reproduce the bug when doing the same?: uninstall LibreOffice completely and then reinstall it using the 64bit installer of 5.3.1RC1?

thanks and regards
muso
Comment 6 muso 2017-03-16 18:30:38 UTC
Today LO 5.3.1.2 was released. i tried this version. I even also deleted Windows' font cache before reinstalling LibreOffice.

The problem persists: ALL (sic!) ODP and PPT documents I have ever created with LibreOffice have now the unreadable text boxes.

I note that when I click into a text box and decrease the font size, the text becomes smaller. But when i click onto the just changed text i see that the size have not changed in the settings: I changed text in size 28 to 14. But in the settings I still see 28 afterwards although that the text appears now smaller in LO.

Any help is highly appreciated!
Comment 7 muso 2017-03-16 18:38:11 UTC
This bug makes me crazy but I now found a workaround:

- open my test file
- save it as *.odp
- close the file and reopen the just created ODP

result: the problem persists

But now do this:

- open my test file
- save it as *.pptx
- close the file and reopen the just created PPTX

result: now everything looks fine.

It is so wierd that I will have now to open my ODP files I once created with LO 5.x and save them as PPTX to fix them.
Comment 8 muso 2017-03-16 18:51:29 UTC
I attached now the fixed PPT file that I created this way:

- opened my attached test file
- saved it as PPTX
- closed the file and then opened the created PPTX
- saved it as PPT

I hope that when you diff my test file and the fixed version you find the problem.
Comment 9 muso 2017-03-16 18:52:24 UTC
Created attachment 131943 [details]
Fixed test file as described in comment 8
Comment 10 Aron Budea 2017-03-17 05:04:14 UTC
Reproduced with 5.3.1.2 / Windows 7 with OpenGL rendering enabled, but not with default rendering. Also not reproduced with the old layout engine ("set SAL_NO_COMMON_LAYOUT=1" in command line before launching LO).

Muso, until the bug is fixed, a simpler workaround is to disable OpenGL by unchecking "Use OpenGL for all rendering" in Tools -> Options...; LibreOffice -> View.

The latest 5.4 master build I had was from the end of February, the bug was still in it, but might've been fixed since...
Comment 11 Aron Budea 2017-03-17 05:07:15 UTC
Oh, found a duplicate report.

*** This bug has been marked as a duplicate of bug 103831 ***
Comment 12 muso 2017-03-17 09:51:24 UTC
(In reply to Aron Budea from comment #10)

> disable OpenGL by unchecking "Use OpenGL for all rendering" in Tools -> Options... -> LibreOffice -> View.

Dear Aron,

thank you so much! This fixes my problem and I can continue my work.

best regards
Muso