Bug 106589 - Invalid saving XLSX documents with hidden rows
Summary: Invalid saving XLSX documents with hidden rows
Status: RESOLVED DUPLICATE of bug 105840
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-17 10:42 UTC by Artem
Modified: 2017-03-17 11:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Source file produced by Excel (15.10 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-03-17 10:44 UTC, Artem
Details
File generated by LibreOffice (2.82 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-03-17 10:45 UTC, Artem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem 2017-03-17 10:42:30 UTC
Description:
When XLSX document contains many hidden rows, LibreOffice saves them incorrectly.

Steps to Reproduce:
1. Open MS Excel
2. Create new spreadsheet
3. Hide all columns except A
4. Hide all rows except 1
5. Save it as test_excel.xlsx
6. Check file size and ensure saved file opens in Excel and looks the same (would be 15 KB)
7. Open LibreOffice
8. Open created document and save it as "test_libreoffice.xlsx"
9. Check resulting file size and open it in Excel


Actual Results:  
- File size is 3MB (i.e. 500x BIGGER)
- File opens long time (10+ seconds, i.e. 10x LONGER)


Expected Results:
- File size is about 15 KB (no data increase)
- File opens as fast as test_excel.xlsx file (~1 second)


Reproducible: Always

User Profile Reset: No

Additional Info:
There is a similar problem with openpyxl. Maybe fix should be done together.

https://bitbucket.org/openpyxl/openpyxl/issues/777/invalid-support-for-hidden-rows


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Artem 2017-03-17 10:44:37 UTC
Created attachment 131959 [details]
Source file produced by Excel
Comment 2 Artem 2017-03-17 10:45:26 UTC
Created attachment 131960 [details]
File generated by LibreOffice
Comment 3 Artem 2017-03-17 10:47:24 UTC
The problem, besides 500x increase in size, is that resulting documents takes 40 seconds to open with Python library and the same 40 seconds to save it later. It simply too long to be used in production.
Comment 4 Xisco Faulí 2017-03-17 10:54:42 UTC
Hello Artem.
Thanks for reporting the bug.
it seems like a duplicate of bug 105840 and it should be fixed in 5.3.1

*** This bug has been marked as a duplicate of bug 105840 ***
Comment 5 Artem 2017-03-17 11:12:47 UTC
I confirm the problem is fixed in 3.5.1.