Bug 106648 - Android: save current work when onSaveInstanceState is called
Summary: Android: save current work when onSaveInstanceState is called
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 107421 118790 (view as bug list)
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2017-03-19 21:33 UTC by Tomaz Vajngerl
Modified: 2018-10-31 01:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomaz Vajngerl 2017-03-19 21:33:12 UTC
When the activity is stopping or onSaveInstanceState is called (whatever the correct event) we need to save the current work to a temp file, and restore it when we continue. If we don't do this then the unsaved changes will be lost which could happen by only switching to another app and back.
Comment 1 Tomaz Vajngerl 2017-09-07 11:50:06 UTC
*** Bug 107421 has been marked as a duplicate of this bug. ***
Comment 2 Commit Notification 2018-08-07 12:30:12 UTC
Mert Tumer committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2fa47f8c0f9e4a7a61f29b4bb8acaf10c861fda1

tdf#106648 save current work when switching to other apps

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2018-09-07 09:49:27 UTC
A polite ping to Mert Tumer:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 4 Mert Tumer 2018-10-06 06:22:26 UTC
*** Bug 118790 has been marked as a duplicate of this bug. ***