Bug 106673 - MSI deployment via GPO fails due to "Add operation failed"
Summary: MSI deployment via GPO fails due to "Add operation failed"
Status: RESOLVED DUPLICATE of bug 45750
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.3.1.1 rc
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-21 10:48 UTC by crysman
Modified: 2017-03-21 14:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crysman 2017-03-21 10:48:45 UTC
Description:
MSI deployment via GPO in Win Server 2012R2 fails due to "Add operation failed. Unable to extract deployment information from the package. Run..."

According to this source
https://www.hass.de/content/libreoffice-add-operation-failed-unable-extract-deployment-information-package

the MSI must be changed (some localization/laguages removed) prior to deployment. That is a very unconvenient obstacle.

I believe users and admins would highly appreciate official MSIs which can be taken "as is" without any further local modifications.

Any chance you fix this in the future?

Steps to Reproduce:
1. Download the official MSI
2. try to deploy it via GPO

Actual Results:  
error message

Expected Results:
working MSI deployment


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 V Stuart Foote 2017-03-21 14:33:39 UTC
This is not our bug.

And discussion of the short-comings of the MS MSI installer packaging are that we would have to give up our interactive multi-language packaging support to fit the limited 254 ch string length that GPO can process. 

There is no requirement to repackage for admins needing GPO deployment as affected admins are expected to modify the msi package anyway to eliminate multi-language support in the package not appropriate to their locale.

See dupe bug, https://bugs.documentfoundation.org/show_bug.cgi?id=45750#c16

*** This bug has been marked as a duplicate of bug 45750 ***