Bug Hunting Session
Bug 106679 - UI: Sidebar: Master Slide button is incorrect
Summary: UI: Sidebar: Master Slide button is incorrect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Vidhey PV
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2017-03-21 15:51 UTC by Xisco Faulí
Modified: 2017-08-03 10:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-03-21 15:51:18 UTC
Steps to reproduce:
1. Open Impress
2. Click on Master Slide button in the Sidebar
3. Button changes to 'Close Master View' -> Correct
4. Click on the slide in order to edit it
5. Click outside the slide

Observed behaviour:
Button should be 'Close Master View'

Expected behaviour:
Button is 'Slide Button'

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 4ba483beccc99d336d0e0bec47b5fd6823b16c16
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Close master button was introduced by commit: https://cgit.freedesktop.org/libreoffice/core/commit/?id=64ff7453408e578b95073db1740bfef4f500a2e4

Code in http://opengrok.libreoffice.org/xref/core/sd/source/ui/sidebar/SlideBackground.cxx. mpEditMaster and mpCloseMaster variables
Comment 1 Yousuf Philips (jay) (retired) 2017-03-23 08:20:20 UTC
Yes i remember this incorrect behaviour from the time the button was introduced, not sure if there is a duplicate bug for this issue.
Comment 2 Commit Notification 2017-06-13 11:25:56 UTC
pv2k committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cea458998745f0084271b41d90c92ad27ad071eb

tdf#106679 UI:SideBar Master Slide Button label corrected

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-07-09 21:06:36 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4eae2eeb4c3942648aa5d32678ddb5bbbae9d221

Slightly different approach to tdf#106679

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Katarina Behrens (CIB) 2017-07-17 08:39:33 UTC
Looks like fixed
Comment 5 Xisco Faulí 2017-08-03 10:24:01 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: 3f16306964d5bb81dda3c681bcabbacadf424e7b
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group