Bug 106690 - FILEOPEN: DOCX: Spacing between bullets is incorrect
Summary: FILEOPEN: DOCX: Spacing between bullets is incorrect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2017-03-22 10:51 UTC by Xisco Faulí
Modified: 2017-04-20 08:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (116.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-22 10:51 UTC, Xisco Faulí
Details
sample2 (115.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-22 18:05 UTC, Xisco Faulí
Details
sample3 (160.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-03-27 16:45 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-03-22 10:51:17 UTC
Created attachment 132066 [details]
sample

Steps:
1. Open attached document
2. Check line "Once the desired conference room is highlighted press the OK button on the Vidyo remote"

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 4ba483beccc99d336d0e0bec47b5fd6823b16c16
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-03-22 10:54:14 UTC
Regression introduced by ( bisected with bibisect-linux-64-5.3 ):

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-18 07:19:50 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-10-18 08:57:33 (GMT)
commit	c486e875de7c8e845594f5043a37ee8800865782 (patch)
tree	321aa0a09cbf02b2d4a0e6a1c1e8ba7f03d27eab
parent	fdd8686987ca4ee693f5f194c8eb482daa69cfef (diff)

tdf#95031 DOCX import: auto spacing inside numbering means no spacing
The WW8 import has code for this in SwWW8ImplReader::AppendTextNode(),
with lots of corner-cases. Not all of that is implemented here yet, but
the bullet list in the bugdoc already looks correct now.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2017-03-22 18:05:29 UTC
Created attachment 132078 [details]
sample2

Another document affected by the same commit in page 2
Comment 3 Xisco Faulí 2017-03-27 16:45:54 UTC
Created attachment 132175 [details]
sample3

another document affected by the same problem
Comment 4 Miklos Vajna 2017-03-31 21:34:57 UTC
Yes, I see the problem, thanks for the bisect.
Comment 5 Commit Notification 2017-04-04 10:06:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1bf7f6a1a50ee9f24a3687240fe6ae390b905a6b

tdf#106690 DOCX import: fix automatic spacing before/after numbered para block

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2017-04-05 11:02:30 UTC
Spacing in files 'sample' and 'sample2' verified in

Version: 5.4.0.0.alpha0+
Build ID: 156f778593ca9c57845076a88c6b544a63e12e7a
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_06:30:54
Locale: es-ES (es_ES); Calc: group

However, the issue is still present in file 'sample3'. I'll create a follow-up bug.
Comment 7 Commit Notification 2017-04-12 12:44:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=776839b8bfc6eed905ce97c6fe32af8deb8d1451&h=libreoffice-5-3

tdf#106690 DOCX import: fix automatic spacing before/after numbered para block

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-04-20 08:45:08 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=41bc9d4d467495c9fbf05c920a41fa299ac0ace3

Related: tdf#106690 DOCX import: don't reduce auto-space accross cells

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.