Bug Hunting Session
Bug 106720 - FILESAVE XLSX: Validity setting not saved for otherwise empty rows
Summary: FILESAVE XLSX: Validity setting not saved for otherwise empty rows
Status: RESOLVED DUPLICATE of bug 41425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2017-03-23 11:37 UTC by Gabor Kelemen
Modified: 2017-08-04 22:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Validity check missing from A4:A5 (5.28 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-03-23 11:37 UTC, Gabor Kelemen
Details
The test file in LO 5.3.1 before saving (115.71 KB, image/png)
2017-03-23 11:37 UTC, Gabor Kelemen
Details
Same file saved as ods (9.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-03-23 12:44 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-03-23 11:37:05 UTC
Created attachment 132095 [details]
Validity check missing from A4:A5

I created the attached test XLSX file in LO 5.3.1 on Win7.

First, I set up a few values to choose from in E1:E3.
Then I set up a validity check in A1, to allow a cell range, for worksheet1!E1:E3 as source. Other settings were left on default.
I extended the content of A1 downwards until A5.

After saving and reopening in LO - and in Excel 2013 as well - the validity check is present in A1:A3 but not in A4 and A5.
Comment 1 Gabor Kelemen 2017-03-23 11:37:41 UTC
Created attachment 132096 [details]
The test file in LO 5.3.1 before saving
Comment 2 Xisco Faulí 2017-03-23 11:45:49 UTC
Could you please attach the document saved as .odt too?
Comment 3 Gabor Kelemen 2017-03-23 12:44:57 UTC
Created attachment 132100 [details]
Same file saved as ods

Sure, in ods the A4, A5 cells can be saved and opened just fine - it opens correctly even in Excel :).
Comment 4 Xisco Faulí 2017-03-23 14:16:01 UTC
Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 1670cc25bc2771e87f7956a4b0dd634abaa4128b
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Aron Budea 2017-03-25 23:50:42 UTC
The bug seems to be in XclExpCellTable::XclExpCellTable( const XclExpRoot& rRoot ).
http://opengrok.libreoffice.org/xref/core/sc/source/filter/excel/xetable.cxx#2437

This is where validation data is collected:
if( ScfTools::CheckItem( rItemSet, ATTR_VALIDDATA, false ) )
http://opengrok.libreoffice.org/xref/core/sc/source/filter/excel/xetable.cxx#2641

However, the large loop in that function ends with the last row where there's data, and in this case there's no more data in rows 4-5, so they aren't considered: the application exits the loop before being able to take care of the validation data there.
Comment 6 Martin Spacek 2017-08-04 22:31:44 UTC

*** This bug has been marked as a duplicate of bug 41425 ***