Bug 106753 - When scroll lock is enabled, arrow keys move whole pages at a time
Summary: When scroll lock is enabled, arrow keys move whole pages at a time
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-24 15:35 UTC by Łukasz
Modified: 2017-04-18 15:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz 2017-03-24 15:35:01 UTC
The whole page moves with the arrow instead of the single cell
Comment 1 m.a.riosv 2017-03-25 00:01:49 UTC
Maybe the scroll was locked on some way.

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 2 Łukasz 2017-03-25 07:57:31 UTC
Good, i'll see if i can help
Comment 3 Łukasz 2017-03-25 09:04:28 UTC
did not help
Comment 4 Łukasz 2017-04-06 18:10:43 UTC
Have not you repaired? :(
Comment 5 m.a.riosv 2017-04-06 22:47:18 UTC
I can't reproduce the issue with any of the versions that I have installed, like
Version: 5.3.2.2 (x64)
Build ID: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: es-ES (es_ES); Calc: group

Maybe you have pushed the block scroll key, even I think it is not used by LibreOffice.
Comment 6 Łukasz 2017-04-07 06:51:08 UTC
how to turn off?
Comment 7 Buovjaga 2017-04-17 16:36:45 UTC
(In reply to Łukasz from comment #6)
> how to turn off?

https://pl.wikipedia.org/wiki/Scroll_Lock
Comment 8 Łukasz 2017-04-17 18:12:31 UTC
Please change to scroll lock on, also
Comment 9 Buovjaga 2017-04-17 18:21:51 UTC
(In reply to Łukasz from comment #8)
> Please change to scroll lock on, also

So.. did you have scroll lock on or off? Are you still seeing the problem?
Comment 10 Łukasz 2017-04-17 18:33:29 UTC
No problem with scroll lock disabled. In libre office 5.2.6, it was fine with scroll lock enabled.
Comment 11 Buovjaga 2017-04-18 15:16:26 UTC
This is a feature, see bug 46200