Bug Hunting Session
Bug 106767 - broken txt file, If UTF8 without BOM
Summary: broken txt file, If UTF8 without BOM
Status: RESOLVED DUPLICATE of bug 61703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-25 20:33 UTC by neverapple88
Modified: 2017-03-26 06:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description neverapple88 2017-03-25 20:33:39 UTC
Description:
Nice work .txt opening if UTF8 with BOM .txt file.
but broken if UTF8 without BOM .txt file.

I check using Hex editor BOM and I can't found setting encoding opened file.

Steps to Reproduce:
1. open .txt without BOM file
2. broken!!

Actual Results:  
text broken.... 
example image : http://stackoverflow.com/questions/27155051/broken-typo3-front-end-encoding
it's just example image from google search

Expected Results:
broken~~


Reproducible: Always

User Profile Reset: No

Additional Info:
I can't english. plz, I want easy english. ;)



User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Aron Budea 2017-03-25 21:11:40 UTC
As a workaround, you can choose "Text - Choose encoding" from file type dropdown in Open dialog.

*** This bug has been marked as a duplicate of bug 61703 ***
Comment 2 neverapple88 2017-03-26 06:41:34 UTC
I'm sorry. I thought there was nowhere. (I searched, but my english is bad)
thank you. Aron Budea.