Download it now!
Bug 106815 - Numbers clipped within vertical texts (OTF+OpenGL)
Summary: Numbers clipped within vertical texts (OTF+OpenGL)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL Vertical-Text
  Show dependency treegraph
 
Reported: 2017-03-28 10:26 UTC by Volga
Modified: 2017-03-30 12:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.48 KB, application/vnd.oasis.opendocument.text)
2017-03-28 10:29 UTC, Volga
Details
Screenshot (75.25 KB, image/png)
2017-03-28 10:31 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-03-28 10:26:38 UTC
Description:
When I use OT-CFF fonts for vertical layout, I found numbers clipped if I enabled OpenGL.

Steps to Reproduce:
1. Copy text from https://developer.mozilla.org/en-US/docs/Web/CSS/writing-mode 
2. Insert -> Frame -> Frame Interactively
3. Paste the text into frame
4. Right click its edge, then choose Object, open its option to make the text vertically
5. Select the whole text within the frame, and set the font as Source Han Sans
6. Copy the frame
7. Select the whole text within the second frame, and set the font as Yu Gothic

Actual Results:  
With Source Han Sans, numbers looks clipped.

Expected Results:
Numbers should rendering completely within vertical layout even if OpenGL is enabled.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.3.2.0.0+ (x64)
Build ID: c8f0a37ff804e6329b21a4b7bfabb0667263c6e5
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: zh-CN (zh_CN); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Volga 2017-03-28 10:29:54 UTC
Created attachment 132214 [details]
Test file
Comment 2 Volga 2017-03-28 10:31:37 UTC
Created attachment 132215 [details]
Screenshot
Comment 3 Volga 2017-03-30 07:25:16 UTC
In LO 5.3.2.1 this problem disappeared.

Version: 5.3.2.1 (x64)
Build ID: 7f6693c08cc110b9721245fc4bd4f1712e0c086c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: zh-CN (zh_CN); Calc: group