Download it now!
Bug 106869 - loading extension with basic script cause parenthesis lost
Summary: loading extension with basic script cause parenthesis lost
Status: RESOLVED DUPLICATE of bug 106529
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-30 10:34 UTC by GUTH Christophe
Modified: 2017-03-30 12:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screen capture of bug (175.04 KB, image/jpeg)
2017-03-30 10:34 UTC, GUTH Christophe
Details
the extension built under LO 5.2.0.2 containing basic script (266.26 KB, application/vnd.openofficeorg.extension)
2017-03-30 10:35 UTC, GUTH Christophe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GUTH Christophe 2017-03-30 10:34:10 UTC
Created attachment 132279 [details]
screen capture of bug

Hello,

I've just installed LO 5.3.1.2 (x64) to see if printing bugs reported are corrected, and to see if my extension (written in LO Basic) works fine with this new version.

The first time i start one of my basic procedure, the basic editor opens to tell my that parenthesis are missings one some function calls.

The same extension loaded in LO 5.2.0.2 works fine.

I did'nt test it on all version since 5.2.0.2 because bugs encountered in printing after 5.2.0.2 are blocking for my work and the work of my coworkers.

It's very annoying to see that LO 5.3.2.1 isn't able to reload an extension.

Thanks in advance
best regards
Comment 1 GUTH Christophe 2017-03-30 10:35:19 UTC
Created attachment 132280 [details]
the extension built under LO 5.2.0.2 containing basic script
Comment 2 GUTH Christophe 2017-03-30 10:42:18 UTC
Sorry, i've forgot something. For a work, I had to load my extension in Loo 5.3.0.2 x64.

Loading extension worked fine at this time.
Comment 3 GUTH Christophe 2017-03-30 11:23:03 UTC
I've tested to load my module on LO 5.3.1.2 32 bits (x86), the same problem occurs, some parenthesis are lost.
Comment 4 GUTH Christophe 2017-03-30 11:41:54 UTC
Hello, i've uninstalled LO 5.3.1.2 and installed Lo 5.3.0.3 x86. When I install my extension, loading my Basic script is fine and all my macros are working. It's a bug that appears in the last released version.
Comment 5 Xisco Faulí 2017-03-30 12:07:54 UTC
Yes, this is a duplicate of bug 106529. it should be fixed in LibreOffice 5.3.2

*** This bug has been marked as a duplicate of bug 106529 ***
Comment 6 Mike Kaganski 2017-03-30 12:26:38 UTC
Just a notice.

It's a bug, but not a bug in newer LO. It's a bug in older LO that just allowed *WRONG* basic syntax to pass. Your extension contains that basic where syntax is incorrect, and older LO just puts virtual closing parenthesis where it sees fit. LO 5.3.1 checks correctly, and shows you the error. As it's decided that this functionality should be only landed in 5.4, it is reverted for now in 5.3.2, but will return in 5.4, and then unfixed extensions will not work anymore.
Comment 7 GUTH Christophe 2017-03-30 12:37:00 UTC
after doing a closer check, I can confirm that this bug was in LO 5.2.0.2 (and 5.3.0.3). There is effectivly a missing parenthesis in my source and LO 5.3.0.3 won't complain about it when i run my scripts. It could be the same origin for Extension TexMaths in bug 106529.

I'll check all my basic scripts to correct this before next version.
Thanks