Bug 106893 - Black area when closing bottom toolbar after a change
Summary: Black area when closing bottom toolbar after a change
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: ARM Android
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-31 03:53 UTC by Ximeng Zu
Modified: 2021-05-21 20:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ximeng Zu 2017-03-31 03:53:45 UTC
How to reproduce:
1. Open a document (.docx or .odt)
2. Touch the edit button (A with underline)
3. Make a change and it takes effect (e.g. bold some text)
4. Touch the edit button (A with underline) again
5. There is black area (which was covered by bottom toolbar)

I think this is due to a missing function call to update viewport after closing the bottom toolbar.
Comment 1 Ximeng Zu 2017-04-05 00:25:32 UTC
After examining the code. I think this bug is largely due to improper handling of soft keyboard open/close actions. More specifically, there are two ways of opening/closing soft keyboard. One is through the button view, the other is through touching on text and pressing back button on the device. When the user uses the two ways alternately, e.g. clicking on button view to open and press back button on device to close, there is this bug occurring.
Comment 2 Ximeng Zu 2017-04-08 23:46:55 UTC
(In reply to Ximeng Zu from comment #1)
> After examining the code. I think this bug is largely due to improper
> handling of soft keyboard open/close actions. More specifically, there are
> two ways of opening/closing soft keyboard. One is through the button view,
> the other is through touching on text and pressing back button on the
> device. When the user uses the two ways alternately, e.g. clicking on button
> view to open and press back button on device to close, there is this bug
> occurring.

I was not totally correct in this comment. This bug is not related to soft keyboard. Rather, it is about a lack of update somewhere. I've been looking for it, but not much luck.
Comment 3 blendergeek 2017-04-18 00:15:03 UTC
I can confirm that this bug exists in the nightly builds of LibreOffice 5.4 on Android 5.1.1 on a Moto G.
Comment 4 Xisco Faulí 2017-04-18 08:51:38 UTC
Moving to NEW as per comment 3
Comment 5 QA Administrators 2018-04-19 02:34:37 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-04-19 03:35:56 UTC Comment hidden (obsolete)
Comment 7 Michael Weghorn 2021-05-21 16:13:25 UTC
With current git master, I can reproduce the issue like this:

1. Open a document (.docx or .odt)
2. tap into the document so that the editing toolbar appears
3. tap the soft keyboard icon in the editing toolbar
4. type some text
5. Touch the soft keyboard button again
5. There is black area (which was covered by soft keyboard before)

Version: 7.2.0.0.alpha1+
Build ID: 128f67e0efa0
Comment 8 Michael Weghorn 2021-05-21 17:26:39 UTC
Pending change https://gerrit.libreoffice.org/c/core/+/115973 fixes the issue for me.
Comment 9 Commit Notification 2021-05-21 20:01:43 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a9eef7849a75ba91806886ea9c96d114c8d56f9

tdf#106893 android: Show whole doc when closing soft keyboard

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.