Bug Hunting Session
Bug 106907 - "Update links when opening" option setting ignored when option is set to "Always"
Summary: "Update links when opening" option setting ignored when option is set to "Alw...
Status: RESOLVED DUPLICATE of bug 92837
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2017-04-01 15:26 UTC by Eric
Modified: 2017-07-23 20:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2017-04-01 15:26:49 UTC
Description:
I have a calc sheet with liks to external data wghich is an html file on disk. In tools->options->LibreOffice Calc->General I set "Updating" to "Always" and closed Calc.
When i re-open calc it stil  prompts me "his file contains links to other files. Should they be updated?"


Steps to Reproduce:
1. create a spradhseet with a lihnk to an external HTML file containing a table
2. In Tools Options Calc General set "Updating" to "Always"
3. Save and close Calc
4. restart calc using this command line example (Stocks.ods is my sheet):
/opt/libreoffice5.3/program/soffice.bin --calc --accept="socket,host=localhost,port=2002;urp" Stocks.ods
5. You will get the  prompt

Actual Results:  
Calc always prompts to update external links on startup

Expected Results:
If I set the Updating Option to "Always" it should not prompt me on startup, it should just proceed as if i said "Yes" to the prompt.


Reproducible: Always

User Profile Reset: No -  this is a fresh install

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

[Information provided by me :-)]
Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 12; OS Version: Linux 4.7; UI Render: default; VCL: x11; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: CL
KDE 4.11.5
Fresh install of LibreOffice from downloaded rpm's

Builds ID: LibreOffice 5.3.1.2


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Julien Nabet 2017-04-01 16:14:25 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.

UX-Team: for Calc and Writer, the function isTrustedLocationUriForUpdatingLinks is called in this case.
Here is its definition:
bool SvtSecurityOptions::isTrustedLocationUriForUpdatingLinks(
    OUString const & uri) const
{
    return GetMacroSecurityLevel() == 0 || uri.isEmpty()
        || uri.startsWithIgnoreAsciiCase("private:")
        || isTrustedLocationUri(uri);
}

See http://opengrok.libreoffice.org/xref/core/unotools/source/config/securityoptions.cxx#isTrustedLocationUri

I think clicking on "Always" for updating should warn about this.
Comment 2 Heiko Tietze 2017-04-03 20:51:59 UTC
Just CC'ing the design ML.
Comment 3 Cor Nouws 2017-07-23 07:43:23 UTC
(In reply to Eric from comment #0)

> Actual Results:  
> Calc always prompts to update external links on startup
> 
> Expected Results:
> If I set the Updating Option to "Always" it should not prompt me on startup,
> it should just proceed as if i said "Yes" to the prompt.

I just found out that the Help reads:
"This setting is treated as On request unless either the global macro security level is set to Low in Tools - Options... - LibreOffice - Security - Macro Security... - Security Level - Low (not recommended) or the document is located in a trusted place defined by Tools - Options... - LibreOffice daily20170720 - Security - Macro Security... - Trusted Sources - Trusted File Locations. " 

So assuming it's not from a trusted location nor the 'security' is set to Low (none), then it works es designed
Comment 4 Cor Nouws 2017-07-23 07:49:09 UTC

*** This bug has been marked as a duplicate of bug 92837 ***
Comment 5 Eric 2017-07-23 11:21:42 UTC
You are right (I tried what you posted), however...
If you go to 'Tools->Options->LibreOffice Calc->General' and click the Help button that info isn't mentioned at all.
Here is what shows up :

Update
Update links when loading
Always
Always updates links while loading a document.
On request
Updates links only on request while loading a document.
Never
Links are never updated while loading a document.


I would expect that the info you found would or should be explained there.
Comment 6 Heiko Tietze 2017-07-23 12:22:22 UTC
CC'ing Olivier for the help question.
Comment 7 Cor Nouws 2017-07-23 20:24:49 UTC
(In reply to Eric from comment #5)

> I would expect that the info you found would or should be explained there.

See https://bugs.documentfoundation.org/show_bug.cgi?id=92837#c36
is has been pushed 2017-05-05 - so only in Master and 5.4.0beta, I gues ;)