Bug Hunting Session
Bug 106977 - With Hardware Acceleration rotated (non-Horizontal) text is not displayed during presentation (OpenGL and CPU only rendering unaffected)
Summary: With Hardware Acceleration rotated (non-Horizontal) text is not displayed dur...
Status: RESOLVED DUPLICATE of bug 107090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-05 13:19 UTC by Tamás Zolnai
Modified: 2017-09-27 14:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Vertical text in ODP (13.32 KB, application/vnd.oasis.opendocument.presentation)
2017-04-05 13:20 UTC, Tamás Zolnai
Details
90 degrees turned text disappears during presentation (13.64 KB, application/vnd.oasis.opendocument.presentation)
2017-09-27 11:59 UTC, Oliver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-04-05 13:19:24 UTC
Description:
Check the attached document which has vertical text also in a table and in a text box. When I start the presentation none of these text is shown on the screen.

Steps to Reproduce:
1. Open attached file
2. Start presentation

Actual Results:  
Texts are not shown during presentation

Expected Results:
Texts should be shown during presentation


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 Tamás Zolnai 2017-04-05 13:20:04 UTC
Created attachment 132356 [details]
Vertical text in ODP
Comment 2 Jacques Guilleron 2017-04-05 14:03:36 UTC
Hi, 

I reproduce with:
LO 5.4.0.0.alpha0+ Build ID: 96a9b38db5fd9c21bffe4274fa7d5083d4bc2ee9
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-03-18_23:07:25
Locale: fr-FR (fr_FR); Calc: CL
and upper versions,
but not with:
LO 5.4.0.0.alpha0+ Build ID: a5c947579253a7f4e784004e18929af5ab22fa28
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-03-02_01:57:01
Locale: fr-FR (fr_FR); Calc: CL

Jacques
Comment 3 Tamás Zolnai 2017-04-07 08:25:04 UTC
Updating the source code and a clean build solved this issue.
Comment 4 Oliver 2017-09-27 11:58:13 UTC
I still have this problem with version :
Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
Threads CPU : 4; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: group

see the attached file : the 90 degrees turned text boxes disappear during presentation (but only on the presentation screen and not on the presenter screen).
Comment 5 Oliver 2017-09-27 11:59:03 UTC
Created attachment 136565 [details]
90 degrees turned text disappears during presentation
Comment 6 V Stuart Foote 2017-09-27 13:30:45 UTC
If only Windows builds, and disabling "Use hardware acceleration" or enabling "Use OpenGL for all rendering" clears issue, this is a duplicate of bug 107090
Comment 7 Oliver 2017-09-27 13:56:37 UTC
yes, disabling user hardware acceleration will resolve the problem
thanks
Comment 8 Jacques Guilleron 2017-09-27 14:01:57 UTC
Hello,

The text is visible during presentation of "90 degrees..." only if I uncheck
"Use hardware acceleration" and keep checked "Use OpenGL for all renderers".
Tried with
LO 5.4.1.2 Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
As said by V Stuart Foote, this is a duplicate of Bug 107090.

*** This bug has been marked as a duplicate of bug 107090 ***
Comment 9 Aron Budea 2017-09-27 14:21:21 UTC
I assume this is because DirectWrite renderer cannot render vertical text. I'd say it's not a duplicate of bug 107090, they seem to be different shortcomings of LO's DirectWrite renderer.