Bug Hunting Session
Bug 107003 - EDITING: Gallery image will increase in size when rotating it after adding a note caption
Summary: EDITING: Gallery image will increase in size when rotating it after adding a ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2017-04-06 18:21 UTC by Telesto
Modified: 2017-07-20 12:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (29.72 KB, application/3dr)
2017-04-06 18:22 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-04-06 18:21:56 UTC
Description:
The size of a gallery image will increase in size under certain (special) circumstances 

Steps to Reproduce:
1. Open attached file
2. Click on the light bulb an rotate it 90 degrees right
3. Add a caption to the image (right click Insert Caption)
4. Deselect everything.
5. Click on the light bulb, an rotate it again 90 degrees left


Actual Results:  
Image will be paper filling

Expected Results:
The size should remain the same.


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-05_23:32:27
Locale: nl-NL (nl_NL); Calc: CL

and in
Version: 5.2.5.0.0+
Build ID: a4d4fbeb623013f6377b30711ceedb38ea4b49f8
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-2, Time: 2016-12-24_14:43:55
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (nl_NL)


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-04-06 18:22:12 UTC
Created attachment 132381 [details]
Example file
Comment 2 Regina Henschel 2017-04-07 15:47:16 UTC
Same as in other bug report. First disable relative width before doing any changes to the image itself.
Comment 3 Telesto 2017-04-07 18:34:28 UTC
@Regina:
I agree it's caused by "relative width" setting (I didn't notice). But I'm still seeing a bug or inconsistency.

The image switches from absolute to relative width when adding a Note caption. Its introduced somewhere after LibO5.0.6.3. But I'm not sure if it's on purpose 
The advance is that makes it possible to resize frame and image at once. However if its intended, why not change the image height also to relative (inconsistent)

I also notice at least two disadvantages:
1. When replacing the image from the note caption frame by deleting the existing image add adding a new one (image size will be absolute)
2. The image size will increase when
a) rotating the image
b) copying the image from the caption frame to a new frame. 

Yes, there is a easy workaround: uncheck 'relative width'. But why should I think of disabling relative width, if I didn't enable it in the first place?
Comment 4 Regina Henschel 2017-04-07 18:43:18 UTC
I had not closed this report, because it has indeed to be discussed, how the current behavior can be improved.
Comment 5 Buovjaga 2017-04-23 16:12:59 UTC
..and off to UX land this goes.
Comment 6 Heiko Tietze 2017-04-24 07:33:17 UTC
Making the object's height relative sounds reasonable. But that might be not easy to calculate as today the frame is not adjusted in height but the image stretched when rotated back with everything set to relative.

Another solution is to protect the rotation when the object is framed and/or relative size is set. The user gets no feedback why the object changes unintentionally and will undo the operation or resize in most cases.
Comment 7 Heiko Tietze 2017-07-18 12:42:27 UTC
Setting to NEW. UX should look into the issue.
Comment 8 Heiko Tietze 2017-07-20 12:39:55 UTC
We talked about the issue in the design meeting. 

The relative setting is needed to adjust the image to the surrounding frame. If you resize the frame you also resize the image. 

Two ideas how to deal with the reported issue:

Option a) is to disable the relative settings before an operation like rotate is applied and to restore the previous state automatically; drawback is that we put a lot of coding effort into a error-prone function. Right now the auto enabling of the relative checkbox doesn't take the user-defined properties into account.

Option b) is to add transparency and let the user decide in the caption dialog whether the relative setting is enabled or not

Both options are not a good solution. So we agreed in the design team to resolve the ticket as WFM. Just keep in mind to disable the option manually before you apply an operation.

It might be good to add some words to the documentation, @Olivier.