Bug 107024 - Moving between elements on main menu flickers (with CPU or default hardware acceleration, but is OK with OpenGL rendering)
Summary: Moving between elements on main menu flickers (with CPU or default hardware a...
Status: RESOLVED DUPLICATE of bug 105863
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-04-08 01:22 UTC by thunderball007
Modified: 2017-05-05 04:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
black box when maximizing (24.35 KB, image/png)
2017-04-09 20:13 UTC, esteban521
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thunderball007 2017-04-08 01:22:32 UTC
When selecting File/Edit/Insert/etc from top row the line flickers momentarily.
Comment 1 V Stuart Foote 2017-04-08 05:15:29 UTC
Confirmed.

On Windows 10 Pro 64-bit en-US with nVidia GPU (driver 21.21.13.7653) with
Version: 5.3.2.1 (x64)
Build ID: 7f6693c08cc110b9721245fc4bd4f1712e0c086c
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: CL

Flicker is not present with OpenGL rendering, but quite noticeable with hardware acceleration, or with CPU only rendering.
 
This was OK with 5.3.0.3 and 5.3.1.2 but goes bad for 5.3.2.1

Needs Windows bibisect

@Michael, Khaled, * -- for 5.3.2.0+ we've moved font layout more completely to DirectWrite but is that now causing a buffering issue that shows up as flicker in the menus?

=-ref-=
https://bugs.documentfoundation.org/show_bug.cgi?id=104242#c12 and resulting shift to DirectWrite from GDI.
Comment 2 Khaled Hosny 2017-04-08 14:57:27 UTC
No idea, some old bug in the DirectWrite code or some such, this code have been there for a long time no changes made to it in this release. Nothing related to HarfBuzz.
Comment 3 esteban521 2017-04-09 20:13:01 UTC
Created attachment 132426 [details]
black box when maximizing

Related to the interface flickering, this also happens
Comment 4 esteban521 2017-04-09 20:16:40 UTC
menu bar flickering when changing betwwen menus. Menu items load one after another taking long to display all the options, window resizing takes long with whole interface flickering and black box displaying when maximizing the window.

Not sure if it is the same problem
 LO 5.3.2.2
 Windows 10 with Intel HD Graphics 3000 and GeForce GT 525M

Neves had this issue with previus LO versions
Comment 5 V Stuart Foote 2017-04-10 03:22:08 UTC
Rather seems there is a relationship between bug 106990 and bug 107024, with OpenGL rendering it does not manifest, but with Default HW rendering or CPU only rendering the issues are present.
Comment 6 V Stuart Foote 2017-04-14 14:10:08 UTC
It has gotten more noticeable at 5.3.2, but closing this for the duplicate.

*** This bug has been marked as a duplicate of bug 105863 ***