Bug 107031 - Dragging and dropping headings from Navigator to document creates a copy instead of a hyperlink (gtk3)
Summary: Dragging and dropping headings from Navigator to document creates a copy inst...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.3
Keywords:
: 101613 (view as bug list)
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2017-04-08 15:50 UTC by Vianney Stroebel
Modified: 2017-04-12 11:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vianney Stroebel 2017-04-08 15:50:25 UTC
Description:
Drag and droping headings from navigator to document create a copy instead of an hyperlink, even when "Insert as Hyperlink" is checked.


Steps to Reproduce:
1. Create a new document
2. Create headings
3. Check "Insert as Hyperlink"
4. Drag and drop heading to document.

Actual Results:  
Heading and the following paragraphs are copied.

Expected Results:
An hyperlink should be inserted.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Part of Bug #101613 seems to describe this bug in a more specific situation.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Vianney Stroebel 2017-04-08 16:16:42 UTC
Update: this bug is happening for me only with the option "SAL_USE_VCLPLUGIN=gtk3", which I need in order for LibreOffice to display correctly.
Comment 2 Xisco Faulí 2017-04-08 20:19:34 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 6152bf9ee9b2e348dee854921a5a5db1cfc72995
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

but not in

Version: 5.4.0.0.alpha0+
Build ID: 6152bf9ee9b2e348dee854921a5a5db1cfc72995
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Caolán McNamara 2017-04-10 12:08:19 UTC
after chasing this around the place, there seems to be a magic flag "ACTION_DEFAULT" and writer won't insert the link unless this is set on the paste event.
Comment 4 Commit Notification 2017-04-10 12:25:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=55e7f73640d754bf0004a0d8a989e0a20de00351

Resolves: tdf#107031 writer depends on ACTION_DEFAULT

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2017-04-10 12:37:33 UTC
fixed in master now, 5-3 backport in gerrit
Comment 6 Cor Nouws 2017-04-10 18:35:32 UTC
*** Bug 101613 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2017-04-12 11:13:45 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3247dce15d041d178fa2a855b53415a80df16a28&h=libreoffice-5-3

Resolves: tdf#107031 writer depends on ACTION_DEFAULT

It will be available in 5.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.