Bug 107041 - Vertical LTR orientation (for Uighur, Mongolian script) impossible in tables
Summary: Vertical LTR orientation (for Uighur, Mongolian script) impossible in tables
Status: RESOLVED DUPLICATE of bug 103720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-09 06:20 UTC by Jonathan Joseph Chiarella
Modified: 2017-04-17 17:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Joseph Chiarella 2017-04-09 06:20:19 UTC
Description:
There is no way to have vertical lined LTR text (e.g., traditional Mongolian) in a table. There is no way to have lines of text within a table flow vertically and then also begin new lines to the right.

Steps to Reproduce:
1. Create a Table in a horizontal line document.

2. Click Table Properties.

3. Go to text orientation.

Actual Results:  
Note that there are only two options, horizontal and vertical. Clicking on the toolbar's LTR and RTL icons will make horizontal lines LTR and RTL and vertical lines top-to-bottom or bottom-to-top within each line.

Expected Results:
However, there is no way to dictate whether vertical lines should progress leftward or rightward.

The only option is to have vertical lines that go from top-to-bottom and then begin new lines to the left.


Reproducible: Always

User Profile Reset: N/A

Additional Info:
5.3 boasted that it supported vertical LTR scripts like traditional Mongolian, but support is not complete.

I am more likely to write documents in horizontal lines, LTR, with sections quoting other languages and other scripts. The only way to display vertical text is with table inserts.

However, the only way to display traditional Mongolian script is to make the entire document vertical LTR in the Page Format options.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Jonathan Joseph Chiarella 2017-04-10 00:58:23 UTC
This also affects text boxes created with the Vertical Type tool.
Comment 2 Buovjaga 2017-04-17 17:04:59 UTC

*** This bug has been marked as a duplicate of bug 103720 ***