Download it now!
Bug 107066 - v 5.1.6.2 on Mac Clicking document in finder doesn't show document window until mouse position moves.
Summary: v 5.1.6.2 on Mac Clicking document in finder doesn't show document window unt...
Status: RESOLVED DUPLICATE of bug 77444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-10 13:03 UTC by Lorand Andahazy
Modified: 2017-04-11 07:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lorand Andahazy 2017-04-10 13:03:40 UTC
This is likely due to the code not using a delegate to initiate the application. 
Example delegate:

#import "AppDelegate.h"
#import "yourapp.h"
@implementation AppDelegate

- (void)applicationDidFinishLaunching:(NSNotification *)aNotification
{
    // Insert code here to initialize your application
    [_window setAlphaValue:1.00];   //etc. as needed
}

- (void)applicationDidBecomeActive:(NSNotification *)aNotification
{
    [_window setAlphaValue:1.00];
}

- (void)applicationDidResignActive:(NSNotification *)aNotification
{
    [_window setAlphaValue: _controller.alphaState];
}

- (NSApplicationTerminateReply)applicationShouldTerminate:(NSApplication *)sender
{
    return NSTerminateNow;      //NSTerminateCancel
}

- (BOOL)applicationShouldTerminateAfterLastWindowClosed:(NSApplication *)theApplication
{
    return YES;
}
@end
Comment 1 Telesto 2017-04-10 18:09:47 UTC
Looks like bug 77444
Comment 2 Alex Thurgood 2017-04-11 07:21:13 UTC

*** This bug has been marked as a duplicate of bug 77444 ***