Bug 107129 - Notebookbar: Priority-x feature doesnt work correctly when resizing the window larger
Summary: Notebookbar: Priority-x feature doesnt work correctly when resizing the windo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Notebookbar-Resize
  Show dependency treegraph
 
Reported: 2017-04-12 19:20 UTC by andreas_k
Modified: 2017-08-20 21:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example file where priority didn't work within ContextContainer (231.30 KB, application/x-designer)
2017-04-12 19:20 UTC, andreas_k
Details
modified version of supplied example file (29.27 KB, application/x-designer)
2017-04-18 01:08 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2017-04-12 19:20:02 UTC
Created attachment 132527 [details]
example file where priority didn't work within ContextContainer

with priority-x you can define that you can show/hide part's of the notebookbar. the problem is, that in ContextContainer (sfxlo-DropdownBox) the priority-x feature didn't work.

In addition the priority-number should define which group will hide first 
 priority-1 (hide first)
 priority-2 (hide after -1)
 ...

and with show it should be the other way arround
 priority-2 (show first)
 priority-1 (show second, last)

thanks
Comment 1 Yousuf Philips (jay) 2017-04-18 01:08:03 UTC
Created attachment 132645 [details]
modified version of supplied example file

(In reply to andreas_k from comment #0)
> with priority-x you can define that you can show/hide part's of the
> notebookbar. the problem is, that in ContextContainer (sfxlo-DropdownBox)
> the priority-x feature didn't work.

The feature does work, as can be tested in the attached file.

> In addition the priority-number should define which group will hide first 
>  priority-1 (hide first)
>  priority-2 (hide after -1)
>  ...

It does do that correctly.

> and with show it should be the other way arround
>  priority-2 (show first)
>  priority-1 (show second, last)

This is the part which is broken, as its doing it in the showing the first hidden rather than the last hidden.
Comment 2 Commit Notification 2017-08-20 19:20:11 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d29dae57ed151be7244aa0a1e2317b30a4c928d

tdf#107129: correct showing order

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 andreas_k 2017-08-20 21:45:33 UTC
Szymon can you please describe what I have to do to use the priority-x feature?