Download it now!
Bug 107133 - Special background color for tabs or groups of notebookbar
Summary: Special background color for tabs or groups of notebookbar
Status: RESOLVED DUPLICATE of bug 107128
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2017-04-13 08:21 UTC by Thomas Lendo
Modified: 2017-04-15 19:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of MSO 2013 ribbons with colored image and table tabs (at the right side) (17.75 KB, image/png)
2017-04-13 08:23 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-04-13 08:21:13 UTC
It should be possible for notebookbar developers to define
* a tab color in tabbed notebookbars or
* a background color of a (contextual) group of icons in the grouped notebookbar.

The attached screenshot shows how MSO Word 2013 colors the contextual tabs to give them a visual emphasis so that the user can see that there is more to select then before.

For a grouped notebookbar without tabs it should be possible to give the contextual group a own background color in a (pre-defined?) transparency level to not to be too offensive.
Comment 1 Thomas Lendo 2017-04-13 08:23:08 UTC
Created attachment 132532 [details]
Screenshot of MSO 2013 ribbons with colored image and table tabs (at the right side)
Comment 2 Yousuf Philips (jay) (retired) 2017-04-13 10:56:29 UTC
As the notebookbar, just like all the UI in LO, is themed by the OS theme, it would be difficult to define a specific color for it, but defining a special OS themed color would likely be possible.

*** This bug has been marked as a duplicate of bug 107128 ***
Comment 3 Thomas Lendo 2017-04-13 18:22:38 UTC
I don't know if Andreas really mean a similar thing than I do. Shades of gray (or whatelse is possible as system color) isn't shiny enough to get user's attention as desired with this bug.