Bug 107231 - Database lists not sorted
Summary: Database lists not sorted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:5.5.0
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2017-04-17 13:11 UTC by Michael
Modified: 2017-06-06 12:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2017-04-17 13:11:33 UTC
In both Edit -> Exchange Database... and Insert -> Field -> More Fields... -> Database, the list of databases is not sorted in any usable order. For a user with a large number of registered databases, it is very difficult to find a particular database. I know in early days of Open Office the list was sorted, and I don't remember what version this was lost, but it has been aggravating for awhile - it's possible that it has never been sorted in LibreOffice.
Comment 1 Buovjaga 2017-04-27 16:51:29 UTC
Confirmed.

Note for confirmation: View - Data sources. Right-click in the list - Registered dbs - New - Browse to open some db file - Ok

It is still sorted alphabetically ascending in 3.6.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: f69424ff90f83136027df3063d4c8ddafdf79faa
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 25th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 2 raal 2017-05-24 15:53:51 UTC
This seems to have begun at the below commit.
Adding Cc: to Stephan Bergmann; Could you possibly take a look at this one? Thanks

268bc358faf4e1d317e07172971e103523ea2da2 is the first bad commit
commit 268bc358faf4e1d317e07172971e103523ea2da2
Author: buildslave <buildslave@tb51.libreoffice.org>
Date:   Thu May 5 18:27:23 2016 +0200

    source-hash-8a0df1b7e50ee4e39be0242ca245627b4eedd7e5

    commit 8a0df1b7e50ee4e39be0242ca245627b4eedd7e5
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Mon Jun 30 16:42:28 2014 +0200
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Mon Jun 30 16:42:43 2014 +0200

        Clean up OutputDevice and derived classes noncopyable-ness

        Change-Id: Id29e52c94a89cac20e29ae0a1f0b9f90ffdfcf09
Comment 3 Stephan Bergmann 2017-05-29 15:02:06 UTC
(In reply to raal from comment #2)
> This seems to have begun at the below commit.

which repo did you use for bibisecting?
Comment 4 Stephan Bergmann 2017-06-02 07:48:06 UTC
(In reply to Stephan Bergmann from comment #3)
> (In reply to raal from comment #2)
> > This seems to have begun at the below commit.
> 
> which repo did you use for bibisecting?

@raal: ping
Comment 5 raal 2017-06-02 12:17:46 UTC
(In reply to Stephan Bergmann from comment #3)
> (In reply to raal from comment #2)
> > This seems to have begun at the below commit.
> 
> which repo did you use for bibisecting?

hmm, you're right - ~/bibisect-win32-44 which is only one not max repo and I often forget it :-( I'll run bisect again
Comment 6 raal 2017-06-02 13:17:02 UTC
~/bibisect-win32-44
$ git bisect log
# bad: [489ffd1df414698b6cea9ab03bf6f663b8b5af7e] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [8aa9fc9a0c92172593d6cd97662116a965db229d] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect start 'latest' 'oldest'
# bad: [897913acd244cb6a5d2f4c2da1d625d9b978edb6] source-hash-ac57362b23859591c088e36b7218f4a606dcf3bb
git bisect bad 897913acd244cb6a5d2f4c2da1d625d9b978edb6
# bad: [dc97f44745f96315fb6c5480705bb5d595d39c6c] source-hash-01c8962f281887db59e581906b89d027a994b52a
git bisect bad dc97f44745f96315fb6c5480705bb5d595d39c6c
# good: [a5a39af2ec486b10b26d6373f58a9b59142106c4] source-hash-a595879302e26a616131aa0cab5de31bb287b37d
git bisect good a5a39af2ec486b10b26d6373f58a9b59142106c4
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# bad: [54a9a5df46b192bd5b9bd44702ef3bffd5730523] source-hash-e2f1fffc81896c0773a18e468635056710927d8f
git bisect bad 54a9a5df46b192bd5b9bd44702ef3bffd5730523
# bad: [f1cbe8b4bb7351ee7ca566e6c29229948fcac423] source-hash-9263b101c39172cbcf04189c515bca80cb15f3aa
git bisect bad f1cbe8b4bb7351ee7ca566e6c29229948fcac423
# good: [22dc367922c4141d54b8130ee266e934a6ae6e5c] source-hash-4523dd0544d762961435429167e41a0834b60cea
git bisect good 22dc367922c4141d54b8130ee266e934a6ae6e5c
# bad: [112921daada24f4799be40fc4e9c53964fdf46b3] source-hash-dc93074f71f91efd8a615ad8f1a5289deb210b75
git bisect bad 112921daada24f4799be40fc4e9c53964fdf46b3
# bad: [268bc358faf4e1d317e07172971e103523ea2da2] source-hash-8a0df1b7e50ee4e39be0242ca245627b4eedd7e5
git bisect bad 268bc358faf4e1d317e07172971e103523ea2da2
# good: [9f82e2a04e84c9dd8a8c13d5e6df86d746239619] source-hash-db89e5ff812e2b807476cdf0a10cd81a3040d79b
git bisect good 9f82e2a04e84c9dd8a8c13d5e6df86d746239619
# good: [b6ad49f648b84b7dbe019864e3ad93b47be36a48] source-hash-547135c0dcd5cd5335e625c24e78986529f9a94b
git bisect good b6ad49f648b84b7dbe019864e3ad93b47be36a48
# first bad commit: [268bc358faf4e1d317e07172971e103523ea2da2] source-hash-8a0df1b7e50ee4e39be0242ca245627b4eedd7e5


http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=547135c0dcd5cd5335e625c24e78986529f9a94b..8a0df1b7e50ee4e39be0242ca245627b4eedd7e5

2014-06-30	Clean up OutputDevice and derived classes noncopyable-ness	Stephan Bergmann	3	-22/+2
2014-06-30	...and ~SystemWindow can recursively destroy its child windows	Stephan Bergmann	1	-2/+0
2014-06-30	writerfilter: use XFastAttributes more efficiently.	Michael Meeks	4	-61/+59
2014-06-30	sw: better encapsulate StyleSheet iterator's list.	Michael Meeks	2	-40/+46
2014-06-30	configmgr: faster / simpler compare for keys.	Michael Meeks	5	-10/+45
2014-06-30	extensions: MSVC tinderbox wants its InternetGetConnectedStateEx	Michael Stahl	1	-0/+1
2014-06-30	Once ~SystemWindow calls ~Window, this is no longer a SystemWindow	Stephan Bergmann	1	-4/+11
2014-06-30	Mark WindowImpl as noncopyable	Stephan Bergmann	1	-1/+4
Comment 7 Stephan Bergmann 2017-06-06 12:24:58 UTC
(In reply to raal from comment #6)
> 2014-06-30	configmgr: faster / simpler compare for keys.	Michael Meeks	5
> -10/+45

That's likely the cause.
Comment 8 Commit Notification 2017-06-06 12:26:04 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7176800239f60cd3e990ddb8a6793a198d4c21e3

tdf#107231 Sort list of databases

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.